An Easy Task

Problem Description

Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?

Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

Note: if year Y is a leap year, then the 1st leap year is year Y.

 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains two positive integers Y and N(1<=N<=10000).

 

Output

For each test case, you should output the Nth leap year from year Y.

 

Sample Input

3
2005 25
1855 12
2004 10000

 

Sample Output

2108
1904
43236

 

#include <bits/stdc++.h>
using namespace std;
int main()
{
	vector <int> v;
	for(int i=1;i<=100000;i++)
	{
		if(i%400==0||(i%4==0&&i%100!=0))
			v.push_back(i);
	}
	int n;
	cin>>n;
	while(n--)
	{
		int y,m,t;
		cin>>y>>m;
		for(int i=0;i<v.size();i++)
		{
			if(v[i]>=y)
			{
				t=i;
				break;
			}	
		}
		cout<<v[t+m-1]<<endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值