(枚举,dfs)Flip Game poj 1753

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
  1. Choose any one of the 16 pieces.
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example:

bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.
Input
The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.
Output
Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).
Sample Input
bwwb
bbwb
bwwb
bwww
Sample Output
4


这个题队伍于我来说的坑点就是没有考虑到本点也要翻转。

然后思路就是dfs暴力枚举

共有2的16次方种情况

每种翻转或不翻转


#include<iostream>
#include<cstdio>
using namespace std;
char s[15][15];
int a[15][15];
int ans;
int judge()
{
    int b=a[1][1];
    for(int i=1; i<=4; ++i)
        for(int j=1; j<=4; ++j)
        {
            if(a[i][j]!=b)
                return 0;
        }
    return 1;
}
void fil(int x,int y)
{
    a[x][y]=!a[x][y];
    if(x-1>=1)
        a[x-1][y]=!a[x-1][y];
    if(x+1<=4)
        a[x+1][y]=!a[x+1][y];
    if(y-1>=1)
        a[x][y-1]=!a[x][y-1];
    if(y+1<=4)
        a[x][y+1]=!a[x][y+1];
}
int dfs(int x,int y,int cnt)
{
    if(judge())
    {
        ans=min(ans,cnt);
        return 0;
    }

    if(x>4)
        return 0;
    int ny=(y+1)%5;
    if(ny==0)
        ny=1;
    int nx=x+(y+1)/5;

    dfs(nx,ny,cnt);

    fil(x,y);
    dfs(nx,ny,cnt+1);
    fil(x,y);

    return 0;
}
int main()
{
    for(int i=1; i<=4; ++i)
        scanf("%s",s[i]+1);

    for(int i=1; i<=4; ++i)
        for(int j=1; j<=4; ++j)
        {
            if(s[i][j]=='b')
                a[i][j]=1;
            else
                a[i][j]=0;
        }
    ans=999999;
    dfs(1,1,0);
    if(ans==999999)
        cout<<"Impossible"<<endl;
    else
        cout<<ans<<endl;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值