Wormholes(bellman-Ford)

Description
While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1.. F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
一个地图,有虫洞(可以回到过去),问有没有可能,从一个地方出发,通过虫洞,能在自己进虫洞之前看到自己。

其实说白了就是找负环,直接套模板(这里的套模板指的是套思路,而不是copy代码,模板手写更容易理解,并且这中模板一点也不复杂,没有copy必要)

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#include<vector>
#include<algorithm>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<vector>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const int maxn = 1005;
int head[505],d[505];
struct Node
{
    int u,v,w,next;
}node[5010];
void add_edge(int u,int v,int w,int tot)
{
    node[tot].u = u;node[tot].v = v;
    node[tot].w = w;
    node[tot].next = head[u];
    head[u] = tot;
}
void relax(int u,int v,int w)
{
    d[v] = min(d[v],d[u] + w);
}
int main()
{
    #ifdef LOCAL
    freopen("C:\\Users\\巍巍\\Desktop\\in.txt","r",stdin);
    //freopen("C:\\Users\\巍巍\\Desktop\\out.txt","w",stdout);
    #endif // LOCAL
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m,w;
        scanf("%d%d%d",&n,&m,&w);
        for(int i = 1;i <= n;i++)head[i] = -1;
        for(int i = 1;i <= m;i++)
        {
            int from,to,wei;
            scanf("%d%d%d",&from,&to,&wei);
            add_edge(from,to,wei,2*i - 1);
            add_edge(to,from,wei,2*i);
        }
        for(int i = 1;i <= w;i++)
        {
            int from,to,wei;
            scanf("%d%d%d",&from,&to,&wei);
            add_edge(from,to,-wei,2*m + i);
        }
        for(int i = 1;i <= n;i++)d[i] = inf;
        d[1] = 0;
        for(int i = 1;i < n;i++)
            for(int j = 1;j <= 2*m + w;j++)
            relax(node[j].u,node[j].v,node[j].w);
        bool flag = 0;
        for(int i = 1;i <= 2*m + w;i++)
        {
            int from = node[i].u;
            int to = node[i].v;
            if(d[to] > d[from] + node[i].w)
            {
                flag = 1;break;
            }
        }
        if(flag)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值