Ant Counting(DP)

Description
Bessie was poking around the ant hill one day watching the ants march to and fro while gathering food. She realized that many of the ants were siblings, indistinguishable from one another. She also realized the sometimes only one ant would go for food, sometimes a few, and sometimes all of them. This made for a large number of different sets of ants!

Being a bit mathematical, Bessie started wondering. Bessie noted that the hive has T (1 <= T <= 1,000) families of ants which she labeled 1..T (A ants altogether). Each family had some number Ni (1 <= Ni <= 100) of ants.

How many groups of sizes S, S+1, …, B (1 <= S <= B <= A) can be formed?

While observing one group, the set of three ant families was seen as {1, 1, 2, 2, 3}, though rarely in that order. The possible sets of marching ants were:

3 sets with 1 ant: {1} {2} {3}
5 sets with 2 ants: {1,1} {1,2} {1,3} {2,2} {2,3}
5 sets with 3 ants: {1,1,2} {1,1,3} {1,2,2} {1,2,3} {2,2,3}
3 sets with 4 ants: {1,2,2,3} {1,1,2,2} {1,1,2,3}
1 set with 5 ants: {1,1,2,2,3}

Your job is to count the number of possible sets of ants given the data above.
Input
* Line 1: 4 space-separated integers: T, A, S, and B

  • Lines 2..A+1: Each line contains a single integer that is an ant type present in the hive
    Output
  • Line 1: The number of sets of size S..B (inclusive) that can be created. A set like {1,2} is the same as the set {2,1} and should not be double-counted. Print only the LAST SIX DIGITS of this number, with no leading zeroes or spaces.
    Sample Input
    3 5 2 3
    1
    2
    2
    1
    3
    Sample Output
    10
    Hint
    INPUT DETAILS:

Three types of ants (1..3); 5 ants altogether. How many sets of size 2 or size 3 can be made?

OUTPUT DETAILS:

5 sets of ants with two members; 5 more sets of ants with three members

有n个蚂蚁家族,每个家族至少一个蚂蚁,并且相互之前无区别,问取出i个蚂蚁有多少种取法(s <= i <= b)

最暴力的办法O(TA^2)
dp[i][j]来讲,可以由dp[i - 1][j - k] (0 <=k<= min(num[i],j)转移而来,然后没有超时……

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#include<vector>
#include<algorithm>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<vector>
#include<stack>
#include<utility>
#include<sstream>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const int maxn = 1005;
int num[1005],dp[100005];
int main()
{
    #ifdef LOCAL
    freopen("C:\\Users\\ΡΡ\\Desktop\\in.txt","r",stdin);
    //freopen("C:\\Users\\ΡΡ\\Desktop\\out.txt","w",stdout);
    #endif // LOCAL
    int t,a,s,b;
    scanf("%d%d%d%d",&t,&a,&s,&b);
    memset(num,0,sizeof(num));
    for(int i = 1;i <= a;i++)
    {
        int x;
        scanf("%d",&x);
        num[x]++;
    }
    memset(dp,0,sizeof(dp));
    dp[0] = 1;
    for(int i = 1;i <= t;i++)
    {
        for(int j = b;j >= 0;j--)
        {
            for(int k = 1;k <= min(num[i],j);k++)
                dp[j] = (dp[j] + dp[j - k])%1000000;
        }
    }
    int ans = 0;
    for(int i = s;i <= b;i++)
        ans = (ans + dp[i])%1000000;
    printf("%d\n",ans);
    return 0;
}

下面讲一下O(TA)的正解- -
刚才那个式子由挑战69页可推导
即是
dp[i][j] = dp[i][j - 1] + dp[i - 1][j] - dp[i - 1][j - 1 - num[i]];
dp[i][j] = dp[i][j - 1] + dp[i - 1][j]);
这是一个恒等式,可以证明,实际含义就是前面的连续段可以用dp[i][j - 1]来表示,对于重合的部分还需要减去,取得的最小值不同,减去的数也不同。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#include<vector>
#include<algorithm>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<vector>
#include<stack>
#include<utility>
#include<sstream>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const int maxn = 1005;
const int mod = 1000000;
int num[1005],dp[2][100005];
int main()
{
    #ifdef LOCAL
    freopen("C:\\Users\\ΡΡ\\Desktop\\in.txt","r",stdin);
    //freopen("C:\\Users\\ΡΡ\\Desktop\\out.txt","w",stdout);
    #endif // LOCAL
    int t,a,s,b;
    scanf("%d%d%d%d",&t,&a,&s,&b);
    for(int i = 1;i <= a;i++)
    {
        int x;
        scanf("%d",&x);
        num[x]++;
    }
    memset(dp,0,sizeof(dp));
    dp[0][0] = dp[1][0] = 1;
    for(int i = 1;i <= t;i++)
    {
        for(int j = 1;j <= b;j++)
        {
            if(j - 1 - num[i] >= 0)
                dp[i&1][j] = (dp[i&1][j - 1] + dp[(i - 1)&1][j] - dp[(i - 1)&1][j - 1 - num[i]] + mod)%mod;
            else
                dp[i&1][j] = (dp[i&1][j - 1] + dp[(i - 1)&1][j])%mod;
        }
    }
    int ans = 0;
    for(int i = s;i <= b;i++)
        ans = (ans + dp[t&1][i])%mod;
    printf("%d\n",ans);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值