Ant Counting(多重集组合数)

原体链接

Language:
Ant Counting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4895 Accepted: 1866
Description

Bessie was poking around the ant hill one day watching the ants march to and fro while gathering food. She realized that many of the ants were siblings, indistinguishable from one another. She also realized the sometimes only one ant would go for food, sometimes a few, and sometimes all of them. This made for a large number of different sets of ants!

Being a bit mathematical, Bessie started wondering. Bessie noted that the hive has T (1 <= T <= 1,000) families of ants which she labeled 1…T (A ants altogether). Each family had some number Ni (1 <= Ni <= 100) of ants.

How many groups of sizes S, S+1, …, B (1 <= S <= B <= A) can be formed?

While observing one group, the set of three ant families was seen as {1, 1, 2, 2, 3}, though rarely in that order. The possible sets of marching ants were:

3 sets with 1 ant: {1} {2} {3}
5 sets with 2 ants: {1,1} {1,2} {1,3} {2,2} {2,3}
5 sets with 3 ants: {1,1,2} {1,1,3} {1,2,2} {1,2,3} {2,2,3}
3 sets with 4 ants: {1,2,2,3} {1,1,2,2} {1,1,2,3}
1 set with 5 ants: {1,1,2,2,3}

Your job is to count the number of possible sets of ants given the data above.
Input

  • Line 1: 4 space-separated integers: T, A, S, and B

  • Lines 2…A+1: Each line contains a single integer that is an ant type present in the hive
    Output

  • Line 1: The number of sets of size S…B (inclusive) that can be created. A set like {1,2} is the same as the set {2,1} and should not be double-counted. Print only the LAST SIX DIGITS of this number, with no leading zeroes or spaces.
    Sample Input

3 5 2 3
1
2
2
1
3
Sample Output

10
Hint

INPUT DETAILS:

Three types of ants (1…3); 5 ants altogether. How many sets of size 2 or size 3 can be made?

OUTPUT DETAILS:

5 sets of ants with two members; 5 more sets of ants with three members

原题就是说有T种蚂蚁,每种蚂蚁都有各自的数量,不同的蚂蚁可以区分,但是同种的蚂蚁无法区分,问你一共可以如果看见从B只蚂蚁到看见S只蚂蚁共可以有多少种可能的情况
用dp[i][j]表示从前i种物品中取出j个的组合总数
那么明显dp[i][j]=从k=0到k=min(j,a[i])求和dp[i-1][j-k]是成立的,但是很明显这样做是要超时的(0(nm^2)),所以就要对k的列举进行优化,那么可以认为每次求组合数的时候是分不算上第i种蚂蚁和算上第i种蚂蚁,前者是dp[i-1][j],后者就稍微复杂一些,先得出dp[i][j-1]代表第i种蚂蚁至少有一个,那么就需要除去第i种蚂蚁被算成有a[i]+1j这么多的情况,那么这就是前i-1种蚂蚁被算成1j-a[i]-1的情况,所以dp状态转移方程如下

if(j-1-a[i]>=0)
        dp[i%2][j]=(dp[(i-1)%2][j]+dp[i%2][j-1]-dp[(i-1)%2][j-a[i]-1] + MOD) % MOD;
else
        dp[i%2][j]=(dp[(i-1)%2][j]+dp[i%2][j-1])%MOD;

下面附上我的代码

#include <algorithm>
#include <iostream>
#include <sstream>
#include <cstring>
#include <cstdio>
#include <cmath>
using namespace std;

#define MOD 1000000
//int MOD = 99990001;
const int INF = 0x3f3f3f3f;
//const LL INFF = 0x3f3f3f3f3f3f3f3fLL;
//const DB EPS = 1e-9;
//const DB OO = 1e20;
//const DB PI = acos(-1.0); //M_PI;
const int fx[] = {-1, 1, 0, 0};
const int fy[] = {0, 0, -1, 1};
const int maxn=100000 + 10;
int a[1005];//代表每种蚂蚁有多少个
int dp[2][maxn];//代表前i中物品中取出j个的组合总数,这里对i的情况要进行滚动数组的优化

int main(){
        int T,A,S,B,res=0;
        dp[0][0]=1;dp[1][0]=1;
        scanf("%d%d%d%d",&T,&A,&S,&B);
        for(int i=0;i<A;i++){
                int t;
                scanf("%d",&t);
                a[t]++;
        }
        for(int i=1;i<=T;i++){//i最小也是1了
                for(int j=1;j<=B;j++){
                        if(j-1-a[i]>=0)//在取模时若出现了减法运算则需要先+Mod再对Mod取模,防止出现负数(如5%4-3%4为负数)
                                dp[i%2][j]=(dp[(i-1)%2][j]+dp[i%2][j-1]-dp[(i-1)%2][j-a[i]-1] + MOD) % MOD;
                        else
                                dp[i%2][j]=(dp[(i-1)%2][j]+dp[i%2][j-1])%MOD;
                }
        }
        for(int j=S;j<=B;j++)
                res = (res + dp[T%2][j])%MOD;//这里一定要把res加进去再MOD,否则就会出问题
        printf("%d\n",res);
        return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

门豪杰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值