PAT 1023 Have Fun with Numbers [大整数运算]

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

---------------------------------------这是题目和解题的分割线---------------------------------------

 no more than 20 digits.这么大的数字还要翻倍,肯定会溢出啦,得用大整数。知识点见【大整数运算】 大整数的存储 | 高精度加法 | 高精度减法。如果想要代码精简一点,这道题可以不开结构体的,就一个数,合一块儿写也成。

#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cstring>

using namespace std;

const int maxN = 35;
int visit[maxN];

//大整数结构体定义 
struct node
{
	int len;
	int num[maxN];
	//结构体定义 
	node()
	{
		len = 0;
		memset(num,0,sizeof(num));
	}
}x,y;

//大整数相加 
node sumBig(node a,node b)
{
	node c;
	int i,t = 0; //进位 
	for(i=0;i<max(a.len,b.len);i++)
	{
		int tmp = a.num[i] + b.num[i] + t;
		//进位,保存取余后的结果 
		if(tmp>=10)
			c.num[c.len++] = tmp%10;
		else
			c.num[c.len++] = tmp;
		//更新进位 
		t = tmp/10;
		visit[c.num[c.len-1]]--; //两倍后出现过的次数-- 
	}
	//如果最高位还有进位 
	if(t>0)
		c.num[c.len++] = t;
	return c;
}

//字符串转数字 
node charToArray(char tmp[])
{
	int n,i;
	node re;
	for(i=strlen(tmp)-1;i>=0;i--)
	{
		re.num[re.len++] = tmp[i] - '0';
		visit[tmp[i]-'0']++; //出现过的数字++ 
	}	
	return re;
}

int main()
{
	char str[maxN];
	int i;
	scanf("%s",str);
	x = y = charToArray(str);
	node s = sumBig(x,y);
	//如果为0,说明++和--互相抵消 
	for(i=0;i<s.len;i++)
		if(visit[s.num[i]]!=0) break;	
	if(i!=s.len)
		printf("No\n");
	else
		printf("Yes\n");
	for(i=s.len-1;i>=0;i--)
		printf("%d",s.num[i]);
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值