PAT 1136 A Delayed Palindrome [字符串反转] [大整数运算]

Consider a positive integer N written in standard notation with k+1 digits a​i​​ as a​k​​⋯a​1​​a​0​​ with 0≤a​i​​<10 for all iand a​k​​>0. Then N is palindromic if and only if a​i​​=a​k−i​​for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C

where A is the original number, B is the reversed A, and Cis their sum. A starts being the input number, and this process ends until C becomes a palindromic number -- in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

Sample Input 1:

97152

Sample Output 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

Sample Input 2:

196

Sample Output 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

--------------------------------------这是题目和解题的分割线--------------------------------------

我怎么感觉这道题之前好像出现过(思考.jpg)

题目意思很简单啦,就是反转再相加,看能不能是回文。字符串反转的方法这道题总结过 PAT 1077 Kuchiguse ,这次用的是string里的reverse函数。有个需要注意的地方,不能直接相加,不然最后一个测试点会运行时错误。题目说了是十位数字,得用大整数,知识点见【大整数运算】 大整数的存储 | 高精度加法 | 高精度减法。还有就是,顺序很重要!A+B,A在前还是B在前很重要,不然错了测试点都不知道怎么回事!

还有两个小发现。

① 关于 no match for 'operator+' (operand types are 'basic_string' and 'int') 的报错。在解题的过程中,我发现c = (index + '0') + c; 会出现这个错误,而改写成 c += index + '0'; 则不会。查了下,看到这篇博客的解释是,编译器把括号里的内容变成了int类型(‘0’表示的是48),必须强制类型转换一下→c = char(index + '0') + c;

② string类型,如果要s[0]、s[1]......这样去赋值,必须事先给该变量一个初始值,不然赋值无效。比如说,必须string s = a;再s[0] = 'a';s[1] = 'b'。而不能string s;再s[0] = 'a';s[1] = 'b'。(我经常在string上踩雷= =以后得多用用才能多发现问题啊!

#include<cstdio>
#include<string>
#include<iostream>
#include<algorithm>

using namespace std;

//大整数相加 
string addBig(string a,string b)
{
	//这里必须有初始值 
	string c = a;
	int index = 0,i;
	//a、b长度一样,无需max(),也可以直接倒着遍历 
	for(i=a.length()-1;i>=0;i--)
	{
		//别忘了数字和字符之间的相互转换('0') 
		int tmp = a[i] -'0' + b[i] -'0' + index;
		c[i] = tmp%10 + '0';
		index = tmp/10;
	}
	//如果还有进位,加到字符串的开头 
	if(index!=0)
		c = char(index + '0') + c;
	return c;
}

int main()
{
	string str,newStr;
	cin>>str;
	newStr = str;
	int cnt = 0;
	reverse(str.begin(),str.end());
	//循环条件,不是回文并且次数在10以内 
	while(newStr!=str&&cnt<10)
	{
		cout<<newStr<<" + "<<str<<" = ";
		newStr = addBig(str,newStr);
		str = newStr;
		cout<<newStr<<endl;
		reverse(str.begin(),str.end());
		cnt++;
	}
	if(cnt>=10)
		cout<<"Not found in 10 iterations.\n";
	else
		cout<<newStr<<" is a palindromic number.\n";
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值