1136. A Delayed Palindrome (20) 大数模拟

1136. A Delayed Palindrome (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Consider a positive integer N written in standard notation with k+1 digits ai as ak...a1a0 with 0 <= ai < 10 for all i and ak> 0. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number)

Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C

where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number -- in this case we print in the last line "C is a palindromic number."; or if a palindromic number cannot be found in 10 iterations, print "Not found in 10 iterations." instead.

Sample Input 1:
97152
Sample Output 1:
97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.
Sample Input 2:
196
Sample Output 2:
196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.


题意:给一个不超过一千位的整数,把他与他的镜像数字相加,直到和为一个对称的数字为止。加十次如果还不是对称的数字也退出

思路:一千位的话直接用字符串读入记为a,每次循环开始检查a是否左右对称,然后fc函数里先求出他的镜像数字b,因为a和b是左右相反的,所以直接从左往右加到ans里面就可以,jin用来标记是否进位,最后需要再检查一下最前面是否多了一位,也就是加完之后jin是否为1。此时ans是反相的,倒过来复制给a就好,同时刚好可以单个字符输出


#include<cstdio>
#include<cstring>

using namespace std;

char a[3000],b[3000],ans[3000];

bool isans(){
	int n=strlen(a);
	int i;
	bool f=true;
	for(i=0;i*i<=n;i++){
		if(a[i]!=a[n-1-i]){
			f=false;
			break;
		}
	}
	return f;
}

void fc(){
	int n=strlen(a);
	int i,j;
	for(i=0;i<n;i++){
		b[i]=a[n-1-i];
	}
	b[i]='\0';
	printf("%s + %s = ",a,b);
	int jin=0,t;
	for(j=0;j<n;j++){
		t=a[j]-'0'+b[j]-'0'+jin;
		if(t>=10){
			jin=1;
			t=t%10;
		}
		else{
			jin=0;
		}
		ans[j]=t+'0';
	}
	if(jin==1){
		ans[j]='1';
		j++;
	}
	ans[j]='\0';
	n=strlen(ans);
	for(i=0;i<n;i++){
		printf("%c",ans[n-1-i]);
		a[i]=ans[n-1-i];
	}
	a[i]='\0';
	printf("\n");
}

int main(){
	int i=0;
	scanf("%s",a);
	for(i=0;i<10;i++){
		if(isans()){
			break;
		}
		fc();
	}
	if(i<10){
		printf("%s is a palindromic number.",a);
	}
	else{
		printf("Not found in 10 iterations.");
	}
	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值