POJ 3468 A Simple Problem with Integers (线段树区间更新经典)

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output
4
55
9
15
Hint
The sums may exceed the range of 32-bit integers.
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 200005;
long long add[maxn*4],sum[maxn*4];
void pushdown(int rt,int m){
	if(add[rt]){
	    add[rt*2]  += add[rt];
	    add[rt*2+1]+= add[rt];
		sum[rt*2]  += add[rt]*(m-m/2);
		sum[rt*2+1]+= add[rt]*(m/2);
		add[rt]=0;
	}
}
void pushup(int rt){
	sum[rt]=sum[rt*2]+sum[rt*2+1];
}
void build(int l,int r,int rt){
	add[rt]=0;
	if(l == r){
		scanf("%lld",&sum[rt]);
		return ;
	}
	int m=(l+r)/2;
	build(l,m,rt*2);
	build(m+1,r,rt*2+1);
	pushup(rt);
}
void update(int L,int R,int m,int l,int r,int rt){
	if(L<=l && R>=r){
		add[rt] += m;
		sum[rt] += (r-l+1)*(long long)m;
		return ;
	}
	pushdown(rt,r-l+1);
	int mid=(l+r)/2;
	if(L<=mid)  update(L,R,m,l,mid,rt*2);
	if(R>mid)  update(L,R,m,mid+1,r,rt*2+1);
	pushup(rt);
}
long long query(int L,int R,int l,int r,int rt){
	if(L<=l && R>=r){
		return sum[rt];
	}
	pushdown(rt,r-l+1);
	int mid = (l+r)/2;
	long long ans=0;
	if(L<=mid)  ans+=query(L,R,l,mid,rt*2);
	if(R>mid)   ans+=query(L,R,mid+1,r,rt*2+1);
	return ans;
}
int main(){
	int n,t;
	int q;
	while((scanf("%d%d",&n,&q))!=EOF){
		build(1,n,1);
		char ch[5];
		while(q--){
			cin>>ch;
		   if(ch[0]== 'Q'){
		   	 int l,r;
		     scanf("%d%d",&l,&r);
		     printf("%lld\n",query(l,r,1,n,1));
		   }
		     
		    else{
		    	int l,r,x;
		    	scanf("%d%d%d",&l,&r,&x);
		    	update(l,r,x,1,n,1);
			}
		}
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值