Largest Rectangle in a Histogram(HDU 1506 dp)

Largest Rectangle in a Histogram

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20289    Accepted Submission(s): 6169


Problem Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
 

Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
 

Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
 

Sample Input
 
 
7 2 1 4 5 1 3 3 4 1000 1000 1000 1000 0
 

Sample Output
 
 
8 4000
 

题目分析:这道题刚开始没有看出来要怎么用到dp,后来发现是用动归去解决边界问题,也就是确定每一个矩形的左右两个边界,由此可以看出,动归也不是一下子就能解决问题的,要慢慢想问题,不能一蹴而就。而且,左边界是从左开始遍历,右边界是从右开始遍历,这样可以最大限度节省时间,利用之前已经求的的结果去得到下一个结果。否则会超时。

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
long long h[100005];
int r[100005],l[100005];
int main()
{
	int n;
	while((scanf("%d",&n))!=EOF)
	{
		if(n == 0)
			break;
			
		memset(h,0,sizeof(h));
		for(int i=1;i<=n;i++)
			cin>>h[i],r[i]=l[i]=i;
		
		for(int i=2;i<=n;i++)
			while(h[i] <= h[l[i]-1] && l[i]-1>0)
				l[i] = l[l[i]-1];
		for(int i=n-1;i>=1;i--)
			while(h[i] <= h[r[i]+1] && r[i]+1<=n)
				r[i] = r[r[i]+1];
		long long maxx=0;
		for(int i=1;i<=n;i++)
		{
			if(h[i]*(r[i]-l[i]+1) > maxx)
				maxx = h[i]*(r[i]-l[i]+1);
		}
		
		cout<<maxx<<endl;
	}
	return 0;
 } 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值