POJ 1836 Alignment 变形的LIS

Alignment
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 15323 Accepted: 4974

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity. 

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line. 

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n). 

There are some restrictions: 
• 2 <= n <= 1000 
• the height are floating numbers from the interval [0.5, 2.5] 

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4

Source


题意:最少去掉这个队列中的多少个士兵后使得每个士兵都可以看到最左边或者最右边的士兵,一个士兵能看到另一个士兵需要这两个士兵之间的士兵的身高小于该士兵;当存在两个很高的士兵在中间,他们的身高之间的关系任意就可以了;能把题意弄明白了基本就不会错那么多次了Orz;

思路:把题意真正弄懂了,就相当于裸的LIS,不过你要求两次LIS,在把这两次的LIS联合起来求出最终的结果;

代码:

#include<cstdio>  
#include<cstring>
#include <algorithm>
#include <cmath>
using namespace std;  
#define maxn 1111
#define inf 0x3f3f3f3f
typedef long long LL;
double d[maxn];
int dp1[maxn],dp2[maxn];
int main()  
{  
#ifdef CDZSC_June
	freopen("t.txt", "r", stdin);  
#endif  
	int n;
	while(~scanf("%d",&n))
	{	
		memset(dp1,0,sizeof(dp1));
		memset(dp2,0,sizeof(dp2));
		for(int i =0; i<n; i++)
		{
			scanf("%lf",&d[i]);
		}
		int max1; dp1[0] = 1;
		for(int i = 1; i<n; i++)
		{
			max1 = 0;
			for(int j = 0; j<i; j++)
			{
				if(d[i] > d[j]){
					max1 = max(max1,dp1[j]);
				}
			}
			dp1[i] = max1+1;
		}
		dp2[n-1] = 1;
		for(int i = n-2; i>=0; i--)
		{
			max1 = 0;
			for(int j = n-1; j>i; j--)
			{
				if(d[i] > d[j]){
					max1 = max(max1,dp2[j]);
				}
			}
			dp2[i] = max1+1;
		}
		max1 = 0;
		for(int i = 0; i<n; i++)
		{
			for(int j = i+1; j<n; j++){
				max1 =max(max1,dp1[i]+dp2[j]);
			}
		}
		printf("%d\n",n - max1);
	}
	return 0;  
}  


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值