poj 1836

Alignment
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 16877 Accepted: 5517

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity. 

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line. 

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n). 

There are some restrictions: 
• 2 <= n <= 1000 
• the height are floating numbers from the interval [0.5, 2.5] 

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4

首先说一下,这个题目貌似比较水

主要的算法就是求最长上升子序列,最长下降子序列

目大意:求删除最少的数,使得从序列中任取一个数h[i],有h[1] ~ h[i]严格单增,或h[i] ~ h[n]严格单减

题目分析:分别从左向右,从右向左求LIS,然后枚举最长合法序列in,则n-in就是最少需要删除的数
简单介绍一下LIS,LIS有两种姿势,一种是O(n^2)的一种是O(nlogn)的


O(n^2)
dp[i]表示从1到i的最长上升子序列的长度,dp[i]初始化为1,第一层循环枚举i,第二层循环j从1到i-1,如果h[j] < h[i]表示出现了一个上升关系,则此时若h[j] + 1 >
h[i]则更新h[i]的值,最长下降也一样

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<string>
#include<vector>
#include<stack>
#include<set>
#include<map>
#include<queue>
#include<algorithm>
using namespace std;
int main(){
	int dph[1005],dpl[1005];
	double height[1005];
	int n;
	int i,j;
	int m,u;
	int ans;
	while(~scanf("%d",&n)){
		for(i=0;i<n;i++){
			scanf("%lf",&height[i]);
		}
		ans=0;
		dph[0]=1;
		for(i=1;i<n;i++){
			m=0;
			for(j=0;j<i;j++){
				if(height[i]>height[j]&&dph[j]>m){
					m=dph[j];
				}
			}
			dph[i]=m+1;
		}
		dpl[n-1]=1;
		for(i=n-2;i>=0;i--){
			m=0;
			for(j=n-1;j>i;j--){
				if(height[i]>height[j]&&dpl[j]>m){
					m=dpl[j];
				}
			}
			dpl[i]=m+1;
		}
		ans=0;
		for(i=0;i<n-1;i++){
			for(j=i+1;j<n;j++){
				ans=max(ans,(dph[i]+dpl[j]));
			}
		}
		printf("%d\n",n-ans);
	}
    return 0;
}

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<string>
#include<vector>
#include<stack>
#include<set>
#include<map>
#include<queue>
#include<algorithm>
using namespace std;
double st1[1005],st2[1005];
int binary(double num,int top,double s[]){
	int low,heigh;
	int mid;
	low=0;
	heigh=top;
	while(low<=heigh){
		mid=(low+heigh)/2;
		if(s[mid]<num){
			low=mid+1;
		}
		else{
			heigh=mid-1;
		}
	}
	return low;
}
int main(){
	int dph[1005],dpl[1005];
	int top1,top2;
	double he[1005];
	int n;
	int ans;
	int i,j;
	int pos;
	while(~scanf("%d",&n)){
		for(i=0;i<n;i++){
			scanf("%lf",&he[i]);
		}
		top1=0;
		top2=0;
		st1[top1]=he[0];
		dph[0]=1;
		for(i=1;i<n;i++){
			if(st1[top1]<he[i]){
				top1++;
				st1[top1]=he[i];
			}
			else{
				pos=binary(he[i],top1,st1);
				st1[pos]=he[i];
			}
			dph[i]=top1+1;
		}
		st2[top2]=he[n-1];
		dpl[n-1]=1;
		for(i=n-2;i>=0;i--){
			if(he[i]>st2[top2]){
				top2++;
				st2[top2]=he[i];
			}
			else{
				pos=binary(he[i],top2,st2);
				st2[pos]=he[i];
			}
			dpl[i]=top2+1;
		}
		ans=0;
		for(i=0;i<n-1;i++){
			for(j=i+1;j<n;j++){
				ans=max(ans,(dph[i]+dpl[j]));
			}
		}
		printf("%d\n",n-ans);
	}
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值