poj3685 多重二分

27 篇文章 0 订阅

 

 

如题:http://poj.org/problem?id=3685

Matrix
Time Limit: 6000MS Memory Limit: 65536K
Total Submissions: 5289 Accepted: 1440

Description

Given a N × N matrix A, whose element in the i-th row and j-th column Aij is an number that equals i2 + 100000 × i + j2 - 100000 × j + i × j, you are to find the M-th smallest element in the matrix.

Input

The first line of input is the number of test case.
For each test case there is only one line contains two integers, N(1 ≤ N ≤ 50,000) and M(1 ≤ MN × N). There is a blank line before each test case.

Output

For each test case output the answer on a single line.

Sample Input

12

1 1

2 1

2 2

2 3

2 4

3 1

3 2

3 8

3 9

5 1

5 25

5 10

Sample Output

3
-99993
3
12
100007
-199987
-99993
100019
200013
-399969
400031
-99939

Source

 

 

 

思路:最先先到的是二分x,C(x):小于x的元素个数是否<m .如何实现C(x)?问题肯定在条件上,i2 + 100000 × i + j2 - 100000 × j + i × j,这是每一个元素的值,分别对于i,j求偏导,发现关于i个偏导恒>0,因此在一列中,行数越大,值越大,因此对于所有列二分x,累加找出了小于<m的个数。

 

 

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
#define ll _int64

ll getx(ll i,ll j)
{
 return i*i+100000*i+j*j-100000*j+i*j;
}
int C(ll x,ll n,ll m) //在所有咧中,小于x的元素个数是否<m
{
 ll i;
 ll cnt=0;
 for(i=1;i<=n;i++)
 {
  ll l=0,r=n+1;
  while(r-l>1)
  {
   int mid=(l+r)/2;
   if(getx(mid,i)>=x)
    r=mid;
   else
    l=mid;
  }
  cnt+=l;
 }
 return cnt<m;
}

int main()
{
 //freopen("C:\\1.txt","r",stdin);
 int t;
 ll n,m;
 cin>>t;
 while(t--)
 {
 scanf("%I64d%I64d",&n,&m);
 ll l=-100000*n,r=n*n+100000*n+n*n+n*n;
  while(r-l>1)
  {
   ll mid=(l+r)/2;
   if(C(mid,n,m))
    l=mid;
   else
    r=mid;
  }
  printf("%I64d\n",l);
 }
 return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值