poj2010 二分中位数

27 篇文章 0 订阅

 

 

如题:http://poj.org/problem?id=2010

Moo University - Financial Aid
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 6010 Accepted: 1789

Description

Bessie noted that although humans have many universities they can attend, cows have none. To remedy this problem, she and her fellow cows formed a new university called The University of Wisconsin-Farmside,"Moo U" for short.

Not wishing to admit dumber-than-average cows, the founders created an incredibly precise admission exam called the Cow Scholastic Aptitude Test (CSAT) that yields scores in the range 1..2,000,000,000.

Moo U is very expensive to attend; not all calves can afford it.In fact, most calves need some sort of financial aid (0 <= aid <=100,000). The government does not provide scholarships to calves,so all the money must come from the university's limited fund (whose total money is F, 0 <= F <= 2,000,000,000).

Worse still, Moo U only has classrooms for an odd number N (1 <= N <= 19,999) of the C (N <= C <= 100,000) calves who have applied.Bessie wants to admit exactly N calves in order to maximize educational opportunity. She still wants the median CSAT score of the admitted calves to be as high as possible.

Recall that the median of a set of integers whose size is odd is the middle value when they are sorted. For example, the median of the set {3, 8, 9, 7, 5} is 7, as there are exactly two values above 7 and exactly two values below it.

Given the score and required financial aid for each calf that applies, the total number of calves to accept, and the total amount of money Bessie has for financial aid, determine the maximum median score Bessie can obtain by carefully admitting an optimal set of calves.

Input

* Line 1: Three space-separated integers N, C, and F

* Lines 2..C+1: Two space-separated integers per line. The first is the calf's CSAT score; the second integer is the required amount of financial aid the calf needs

Output

* Line 1: A single integer, the maximum median score that Bessie can achieve. If there is insufficient money to admit N calves,output -1.

Sample Input

3 5 70
30 25
50 21
20 20
5 18
35 30

Sample Output

35

Hint

Sample output:If Bessie accepts the calves with CSAT scores of 5, 35, and 50, the median is 35. The total financial aid required is 18 + 30 + 21 = 69 <= 70.

Source

 

 

思路:上次做这一题使用的是优先队列的预处理,看了二分后再看这一题,看到中位数就想到二分,于是想对中位数进行二分,C(x):当前数作为中位数和<=f?

再对这个中位数左边和右边的aid排序,判断和是否<=f,

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define MAXC 100005

struct node
{
 int score,aid;
 int id;
}cows[MAXC],temp[MAXC];

bool cmp_score(node a,node b)
{
 return a.score<b.score;
}
bool cmp_aid(node a,node b)
{
 return a.aid<b.aid;
}
int C(int x,int c,int n,int f) //以下标x作为中位数的数据为中心选取n个可能的最大和<=f?
{
 int i;
 int cnt_low=0,cnt_high=0;
 int sum=cows[x].aid;
 for(i=0;i<c;i++)
 {
  if(temp[i].id<cows[x].id&&sum+temp[i].aid<=f&&cnt_low<(n-1)/2)
  {
   cnt_low++;
   sum+=temp[i].aid;
  }
  if(temp[i].id>cows[x].id&&sum+temp[i].aid<=f&&cnt_high<(n-1)/2)
  {
   cnt_high++;
   sum+=temp[i].aid;
  }
 }
 if(cnt_low<(n-1)/2&&cnt_high<(n-1)/2)
  return -1;
 else if(cnt_low<(n-1)/2)
  return 1;
 else if(cnt_high<(n-1)/2)
  return 0;
 else return 2;
}
int main()
{
// freopen("C:\\Users\\Administrator\\Desktop\\1\\finance.5.in","r",stdin);
 int n,c,f;
 cin>>n>>c>>f;
 int i;
 for(i=0;i<c;i++)
  cin>>cows[i].score>>cows[i].aid;
 sort(cows,cows+c,cmp_score);
 for(i=0;i<c;i++)
  cows[i].id=i;
 for(i=0;i<c;i++)
  temp[i]=cows[i];
 sort(temp,temp+c,cmp_aid);
 int l=-1,r=c;
 int ans=-1;
 while(r-l>1)
 {
  int mid=(l+r)/2;
  int t=C(mid,c,n,f);
  if(t==-1)
   break;
  else if(t==1)
   l=mid;
  else if(t==0)
   r=mid;
  else
  {
   ans=cows[mid].score;
   l=mid;
  }
 }
 cout<<ans<<endl;
 return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值