Tree Cutting 树形dp

After Farmer John realized that Bessie had installed a “tree-shaped” network among his N (1 <= N <= 10,000) barns at an incredible cost, he sued Bessie to mitigate his losses.

Bessie, feeling vindictive, decided to sabotage Farmer John’s network by cutting power to one of the barns (thereby disrupting all the connections involving that barn). When Bessie does this, it breaks the network into smaller pieces, each of which retains full connectivity within itself. In order to be as disruptive as possible, Bessie wants to make sure that each of these pieces connects together no more than half the barns on FJ.

Please help Bessie determine all of the barns that would be suitable to disconnect.
Input
* Line 1: A single integer, N. The barns are numbered 1..N.

  • Lines 2..N: Each line contains two integers X and Y and represents a connection between barns X and Y.
    Output
  • Lines 1..?: Each line contains a single integer, the number (from 1..N) of a barn whose removal splits the network into pieces each having at most half the original number of barns. Output the barns in increasing numerical order. If there are no suitable barns, the output should be a single line containing the word “NONE”.
    Sample Input
    10
    1 2
    2 3
    3 4
    4 5
    6 7
    7 8
    8 9
    9 10
    3 8
    Sample Output
    3
    8
    Hint
    INPUT DETAILS:

The set of connections in the input describes a “tree”: it connects all the barns together and contains no cycles.

OUTPUT DETAILS:

If barn 3 or barn 8 is removed, then the remaining network will have one piece consisting of 5 barns and two pieces containing 2 barns. If any other barn is removed then at least one of the remaining pieces has size at least 6 (which is more than half of the original number of barns, 5).

树形dp入门题

  • 注意:树的存储方式:vector数组
  • 如何防止树的节点再访问父节点:在递归时可以加一个参数记录父节点。
  • 注意初始化。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <vector>
#define maxn 10010
using namespace std;
int tree[maxn];
int pre[maxn];
int ans[maxn];
int g[maxn][maxn];
int cnt=0;
int n;
int vis[maxn];
vector<int> f[maxn];
int dfs(int fx,int x)
{
    int a=0;
    int t=1;
    for(int i=0;i<f[x].size();i++)
    {
        if(f[x][i]==fx)continue;
        int tmp=dfs(x,f[x][i]);
        t+=tmp;
        a=max(a,tmp);
    }

    ans[x]=a;
    return tree[x]=t;
}
void solve()
{
    dfs(-1,1);
    bool flag=true;
    for(int i=1;i<=n;i++)
    {
        if(ans[i]<=n/2&&n-tree[i]<=n/2)
        {
            flag=false;
            printf("%d\n",i);
        }
    }
    if(flag)puts("NONE");
}

void init()
{
    memset(tree,0,sizeof(tree));
    for(int i=1;i<=n;i++)
    {
        f[i].clear();
    }
}


int main()
{
    int a,b;
    while(scanf("%d",&n)==1)
    {
        init();
        for(int i=0;i<n-1;i++)
        {
            scanf("%d%d",&a,&b);
            f[a].push_back(b);
            f[b].push_back(a);
        }
        solve();
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值