POJ-1562 Oil Deposits

Oil Deposits
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 17678 Accepted: 9383

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

Source

题意:搜油田块数,只要@上下左右斜上斜下八个方位有@符号,就代表是同一块油田。
思路:从左上角开始搜索,遍历8个方位,在坐标合法的情况下判断当前字符,如果是@则进一步深搜此坐标并将此坐标字符改为*避免再次访问。细节处理,注意坐标合法性,避免数组越界。
#include<iostream>
#include<cstring>
#include<queue>
#define MAX 100
using namespace std;
char graph[MAX][MAX+1]={0};
int ans=0;
int M,N;
void DFS(int x,int y)
{
    graph[x][y]='*';
    for(int i=-1;i<=1;i++)
        for(int j=-1;j<=1;j++)
        {
            int xx=x+i,yy=y+j;
            if(xx>=0 && xx<= N-1 && yy>=0 && yy<=M-1 && graph[xx][yy]=='@')
                DFS(xx,yy);
        }
    return ;
}
int main()
{
    while(cin >> N >> M && N &&M)
    {
        ans=0;
        memset(graph,0,sizeof(graph));
        for(int i=0;i<N;i++)
            for(int j=0;j<M;j++)
                cin >> graph[i][j];
        for(int i=0;i<N;i++)
            for(int j=0;j<M;j++)
            {
                if(graph[i][j]=='@')
                {
                    DFS(i,j);
		    ans++;
                }
            }
        cout << ans << endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值