Fermat's theorem states that for any prime number p and for any integer a > 1, ap = a(mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-a pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-apseudoprimes for all a.)
Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-apseudoprime.
Input
Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.
Output
For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".
Sample Input
3 2 10 3 341 2 341 3 1105 2 1105 3 0 0
Sample Output
no no yes no yes yes
题目大意:费马定理:a^p = a(mod p) (a为大于1的整数,p为素数),一些非素数p,同样也符合上边的
定理,这样的p被称作基于a的伪素数,给你p和a,判断p是否是基于a的伪素数
思路:很简单的快速幂取余+素性判断
则进行快速幂取余判断是否满足条件,然后在判断它不是素数输出yes,否则输出no
#include<iostream>
using namespace std;
typedef long long LL;
LL fast_mod(LL a,LL b,LL mod)
{
LL ans=1;
while(b){
if(b&1)
ans=ans*a%mod;//写成ans*=a%mod就不对
b>>=1;
a=a*a%mod;
}
return ans;
}
int prime(LL x)
{
if(x==1) return 0;
for(int i=2;i*i<=x;i++){
if(x%i==0) return 0;
}
return 1;
}
int main()
{
LL p,a;
while(cin>>p>>a,p!=0&&a!=0){
if(fast_mod(a,p,p)==a&&!prime(p))
cout<<"yes"<<endl;
else
cout<<"no"<<endl;
}
return 0;
}