hdu 1525 Euclid's Game

12 篇文章 0 订阅

Euclid's Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1095    Accepted Submission(s): 501


Problem Description
Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7): 

25 7
11 7
4 7
4 3
1 3
1 0 

an Stan wins. 

 

Input
The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.
 

Output
For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed. 

 

Sample Input
  
  
34 12 15 24 0 0
 

Sample Output
  
  
Stan wins Ollie wins

给出两个数,m和n,将大的数减去小的数的倍数,但得到的数要是非负数,使最终有一个数为0的话就胜了。

思路:当m/n=1时,只有一种路线,若两个玩家足够聪明,他们就知道这样下去谁会赢,然而谁到了m/n>=2这种局面,谁就可以选择走多少步到达m/n=1这种局面,也就是说谁到了m/n>=2这种局面谁就一定能赢。如果一开始给出m/n=1这种局面,循环下去就知道是谁赢了。
AC代码:
#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;
int main()
{
    int m,n;
    while(cin>>m>>n)
    {
        if(!m&&!n) break;
        int cnt=1;
        while(1)
        {
            if(m<n) swap(m,n);
            if(n==0||m==0||m%n==0||m/n>=2) break;
            m%=n;
            cnt++;
        }
        if(cnt%2==1)
        cout<<"Stan wins"<<endl;
        else
        cout<<"Ollie wins"<<endl;


    }
   return 0;

}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值