hdu Uncle Tom's Inherited Land*(最大匹配)

Uncle Tom's Inherited Land*

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 967    Accepted Submission(s): 422
Special Judge


Problem Description
Your old uncle Tom inherited a piece of land from his great-great-uncle. Originally, the property had been in the shape of a rectangle. A long time ago, however, his great-great-uncle decided to divide the land into a grid of small squares. He turned some of the squares into ponds, for he loved to hunt ducks and wanted to attract them to his property. (You cannot be sure, for you have not been to the place, but he may have made so many ponds that the land may now consist of several disconnected islands.)

Your uncle Tom wants to sell the inherited land, but local rules now regulate property sales. Your uncle has been informed that, at his great-great-uncle's request, a law has been passed which establishes that property can only be sold in rectangular lots the size of two squares of your uncle's property. Furthermore, ponds are not salable property.

Your uncle asked your help to determine the largest number of properties he could sell (the remaining squares will become recreational parks). 

 

Input
Input will include several test cases. The first line of a test case contains two integers N and M, representing, respectively, the number of rows and columns of the land (1 <= N, M <= 100). The second line will contain an integer K indicating the number of squares that have been turned into ponds ( (N x M) - K <= 50). Each of the next K lines contains two integers X and Y describing the position of a square which was turned into a pond (1 <= X <= N and 1 <= Y <= M). The end of input is indicated by N = M = 0.
 

Output
For each test case in the input your program should first output one line, containing an integer p representing the maximum number of properties which can be sold. The next p lines specify each pair of squares which can be sold simultaneity. If there are more than one solution, anyone is acceptable. there is a blank line after each test case. See sample below for clarification of the output format.
 

Sample Input
  
  
4 4 6 1 1 1 4 2 2 4 1 4 2 4 4 4 3 4 4 2 3 2 2 2 3 1 0 0
 

Sample Output
  
  
4 (1,2)--(1,3) (2,1)--(3,1) (2,3)--(3,3) (2,4)--(3,4) 3 (1,1)--(2,1) (1,2)--(1,3) (2,3)--(3,3)
 

Source
 

Recommend
LL

这道题的亮点在于把整个棋盘的格子由i+j的奇偶性划分,这样就可以使二分图的两个集合没有交集了

#include <stdio.h>
#include <string.h>

int map[105][105];
int match[105][5];
bool vist[105];
int link[105];
struct Node{
    int x,y;
}s[105];

bool Crossroad(int x){
    for(int i = 1;i <= match[x][0];i++){
        int tem = match[x][i];
        if(!vist[tem]){
            vist[tem] = 1;
            if(link[tem] == -1 || Crossroad(link[tem])){
				link[tem] = x;
                return 1;
            }
        }
    }
    return 0;
}

int Hugary(){
    int ans = 0;
    for(int i = 1;i < 105;i+=2){
        memset(vist,0,sizeof(vist));
        if(Crossroad(i)){
            ans++;}
    }
    return ans;
}

int main(){
    int n,m,k;
    int i,j;
    int a,b;
    int counta,countb;

    while(scanf("%d%d",&n,&m) && n && m){
        counta = 1;countb = 2;
        memset(map,-1,sizeof(map));
        memset(match,0,sizeof(match));
        memset(link,-1,sizeof(link));
        scanf("%d",&k);
        while(k--){
            scanf("%d%d",&a,&b);
            map[a][b] = 0;
        }
        for(i = 1;i <= n;i++){
            for(j = 1;j <= m;j++){
                if(map[i][j]){
                    if((i + j) % 2){
                        map[i][j] = counta;
                        s[counta].x = i;
                        s[counta].y = j;
                        counta += 2;
                    }
                    else{
                        map[i][j] = countb;
                        s[countb].x = i;
                        s[countb].y = j;
                        countb += 2;
                    }
                }
            }
        }
        for(i = 1;i <= n;i++)
            for(j = 1;j <= m;j++){
                if(map[i][j] && (i+j) % 2){
                    if((i-1) > 0 && map[i-1][j]){
                        int X = map[i][j];
                        int Y = map[i-1][j];
                        match[X][0]++;
                        int num = match[X][0];
                        match[X][num] = Y;
                    }
                    if((i+1) <= n && map[i+1][j]){
                        int X = map[i][j];
                        int Y = map[i+1][j];
                        match[X][0]++;
                        int num = match[X][0];
                        match[X][num] = Y;
                    }
                    if((j-1) > 0 && map[i][j-1]){
                        int X = map[i][j];
                        int Y = map[i][j-1];
                        match[X][0]++;
                        int num = match[X][0];
                        match[X][num] = Y;
                    }
                    if((j+1) <= m && map[i][j+1]){
                        int X = map[i][j];
                        int Y = map[i][j+1];
                        match[X][0]++;
                        int num = match[X][0];
                        match[X][num] = Y;
                    }
                }
            }
        printf("%d\n",Hugary());
        for(i = 2;i < 105;i+=2)
            if(link[i] != -1)
                printf("(%d,%d)--(%d,%d)\n",s[link[i]].x,s[link[i]].y,s[i].x,s[i].y);
        printf("\n");
    }
     return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园整体解决方案是响应国家教育信息化政策,结合教育改革和技术创新的产物。该方案以物联网、大数据、人工智能和移动互联技术为基础,旨在打造一个安全、高效、互动且环保的教育环境。方案强调从数字化校园向智慧校园的转变,通过自动数据采集、智能分析和按需服务,实现校园业务的智能化管理。 方案的总体设计原则包括应用至上、分层设计和互联互通,确保系统能够满足不同用户角色的需求,并实现数据和资源的整合与共享。框架设计涵盖了校园安全、管理、教学、环境等多个方面,构建了一个全面的校园应用生态系统。这包括智慧安全系统、校园身份识别、智能排课及选课系统、智慧学习系统、精品录播教室方案等,以支持个性化学习和教学评估。 建设内容突出了智慧安全和智慧管理的重要性。智慧安全管理通过分布式录播系统和紧急预案一键启动功能,增强校园安全预警和事件响应能力。智慧管理系统则利用物联网技术,实现人员和设备的智能管理,提高校园运营效率。 智慧教学部分,方案提供了智慧学习系统和精品录播教室方案,支持专业级学习硬件和智能化网络管理,促进个性化学习和教学资源的高效利用。同时,教学质量评估中心和资源应用平台的建设,旨在提升教学评估的科学性和教育资源的共享性。 智慧环境建设则侧重于基于物联网的设备管理,通过智慧教室管理系统实现教室环境的智能控制和能效管理,打造绿色、节能的校园环境。电子班牌和校园信息发布系统的建设,将作为智慧校园的核心和入口,提供教务、一卡通、图书馆等系统的集成信息。 总体而言,智慧校园整体解决方案通过集成先进技术,不仅提升了校园的信息化水平,而且优化了教学和管理流程,为学生、教师和家长提供了更加便捷、个性化的教育体验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值