Poj 1082 (博弈)

Calendar Game
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4494 Accepted: 2099

Description

Adam and Eve enter this year's ACM International Collegiate Programming Contest. Last night, they played the Calendar Game, in celebration of this contest. This game consists of the dates from January 1, 1900 to November 4, 2001, the contest day. The game starts by randomly choosing a date from this interval. Then, the players, Adam and Eve, make moves in their turn with Adam moving first: Adam, Eve, Adam, Eve, etc. There is only one rule for moves and it is simple: from a current date, a player in his/her turn can move either to the next calendar date or the same day of the next month. When the next month does not have the same day, the player moves only to the next calendar date. For example, from December 19, 1924, you can move either to December 20, 1924, the next calendar date, or January 19, 1925, the same day of the next month. From January 31 2001, however, you can move only to February 1, 2001, because February 31, 2001 is invalid.

A player wins the game when he/she exactly reaches the date of November 4, 2001. If a player moves to a date after November 4, 2001, he/she looses the game.

Write a program that decides whether, given an initial date, Adam, the first mover, has a winning strategy.

For this game, you need to identify leap years, where February has 29 days. In the Gregorian calendar, leap years occur in years exactly divisible by four. So, 1993, 1994, and 1995 are not leap years, while 1992 and 1996 are leap years. Additionally, the years ending with 00 are leap years only if they are divisible by 400. So, 1700, 1800, 1900, 2100, and 2200 are not leap years, while 1600, 2000, and 2400 are leap years.

Input

The input consists of T test cases. The number of test cases (T ) is given in the first line of the input file. Each test case is written in a line and corresponds to an initial date. The three integers in a line, YYYY MM DD, represent the date of the DD-th day of MM-th month in the year of YYYY. Remember that initial dates are randomly chosen from the interval between January 1, 1900 and November 4, 2001.

Output

Print exactly one line for each test case. The line should contain the answer "YES" or "NO" to the question of whether Adam has a winning strategy against Eve. Since we have T test cases, your program should output totally T lines of "YES" or "NO".

Sample Input

3 
2001 11 3 
2001 11 2 
2001 10 3 

Sample Output

YES
NO
NO

Source

Taejon 2001

把博弈和日历结合在一起的题目,其实没什么,按照题目要求在日历上递推一下状态即可。(ps最后把状态表打出来,可以发现一条非常简单的规律。)
#include <cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn = 2000 + 5;
const int M[15] = {0,31,28,31,30,31,30,31,31,30,31,30,31};
int tag[maxn][15][35];

void pre(){
    memset(tag,0,sizeof(tag));
    for(int i = 3;i <= 30;i++) tag[2001][11][i] = 1;
    tag[2001][11][2] = 0;
    tag[2001][11][1] = 1;
    tag[2011][10][31] = 0;
    int d = 30,y = 2001,m = 10;
    int ny,nm,nd;
    while(y >= 1900){
        int tem1 = 1,tem2 = 1;

        nd = d + 1;
        nm = m;
        ny = y;
        int c = M[nm];
        if(nm == 2 && (ny%4 == 0 && ny != 1900) ) c++;
        if(nd > c){
            nd = 1;
            nm++;
        }
        if(nm > 12){
            ny++;
            nm = 1;
        }
        tem1 = tag[ny][nm][nd];

        nd = d;
        nm = m+1;
        ny = y;
        if(nm > 12){
            ny++;
            nm = 1;
        }
        c = M[nm];
        if(nm == 2 && (ny%4 == 0 && ny != 1900) ) c++;

        if(nd <= c) tem2 = tag[ny][nm][nd];
        if(tem1 == 1 && tem2 == 1) tag[y][m][d] = 0;
        else tag[y][m][d] = 1;

        d--;
        if(d <= 0){
            m--;
            if(m <= 0){
                y--;
                m = 12;
            }
            d = M[m];
            if(m == 2 && (y%4 == 0 && y != 1900) ) d++;
        }
    }
}

int main(){
    int t;
    pre();
    scanf("%d",&t);
    while(t--){
        int y,m,d;
        scanf("%d%d%d",&y,&m,&d);
        if(tag[y][m][d] == 1) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值