1015 Reversible Primes

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line “Yes” if N is a reversible prime with radix D, or “No” if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No

解题思路:看题太快,题目要求原先的数和反转之后的数都是素数才输出Yes,一直以为是反转后的数是素数就好了,还有判断素数居然写错了,坑爹。

#include<iostream>
#include<stdio.h>
#include<string>
#include<math.h>
using namespace std;
int reverseNum(int num, int d){
    string reNum = "";
    while (num){
        reNum += (num%d) + '0';
        num /= d;
    }
    int ret = 0;
    for (int i = 0; i < reNum.length(); i++){
        ret += (reNum[reNum.length() - i - 1] - '0')*(int)pow(d*1.0, i*1.0);
    }
    return ret;
}
bool isPrime(int n){
    if (n < 2){
        return false;
    }
    for (int i = 2; i*i <= n; i++){
        if (n%i == 0){
            return false;
        }
    }
    return true;
}
int priFlag[100005];
int main(){
    for (int i = 0; i < 100005; i++){
        if (isPrime(i)){
            priFlag[i] = 1;
        }
        else{
            priFlag[i] = 0;
        }
    }
    for (int n; scanf("%d", &n) != EOF && n >= 0;){
        int d;
        scanf("%d", &d);
        int renum = reverseNum(n, d);
        if (priFlag[renum] && priFlag[n]){
            printf("Yes\n");
        }
        else{
            printf("No\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值