poj 3468 线段树(区间更新

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 102779 Accepted: 32092
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15


题意:Q:输出一个区间的和

   C:   给一个区间的每一个数都加上一个值。

思路:懒操作+区间更新


代码:


#include <iostream>
#include <cstdio>
#include <cstdlib>
#include<cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <cctype>
#include<queue>
#include<map>
#include<stack>
using namespace std;
typedef long long ll;

const int maxn = 200005;
struct P{
	int l,r;
	ll sum,add;
	void fun(ll tem){
		sum += tem*(r-l+1);
		add += tem;
	}
}tree[maxn*4];
ll a[maxn];

void push_up(int id){
	tree[id].sum = tree[id<<1].sum + tree[id<<1|1].sum;
}

void push_down(int id){
	if(tree[id].add){
		tree[id<<1].fun(tree[id].add);
		tree[id<<1|1].fun(tree[id].add);
		tree[id].add = 0;
	}
}

void creatTree(int id,int l,int r){
	tree[id].l = l,tree[id].r = r;
	tree[id].add = tree[id].sum = 0;
	if(l == r)
		tree[id].sum = a[l];
	else{
		int mid = (l+r)>>1;	
		creatTree(id<<1,l,mid);
		creatTree(id<<1|1,mid+1,r);
		push_up(id);
	}
}

void update(int id,int st,int ed,ll val){
	int l = tree[id].l,r = tree[id].r;
	if(st<=l && r <=ed){
		tree[id].fun(val);
	}
	else{
		push_down(id);
		int mid = (l+r)>>1;
		if(st<=mid)	update(id<<1,st,ed,val);
		if(ed>mid)	update(id<<1|1,st,ed,val);
		push_up(id);
	}
}

ll findTree(int id,int st,int ed){
	int l = tree[id].l,r = tree[id].r;
	if(st<=l&&r<=ed){
		return tree[id].sum;
	}
	else{
		push_down(id);
		int mid = (l+r)>>1;
		ll sum1=0,sum2=0;
		if(st<=mid)	sum1 = findTree(id<<1,st,ed);
		if(ed>mid)	sum2 = findTree(id<<1|1,st,ed);
		return sum1+sum2;
	}
}

int main(){
	int n,m;
	scanf("%d%d",&n,&m);
	for(int i=1 ;i<=n ;i++)	scanf("%lld",&a[i]);
	creatTree(1,1,n);
	char str[55];
	while(m--){
		scanf("%s",str);
		if(str[0] == 'Q'){
			int t1,t2;
			scanf("%d%d",&t1,&t2);
			printf("%lld\n",findTree(1,t1,t2));
		}
		else{
			int t1,t2;
			ll val;
			scanf("%d%d%lld",&t1,&t2,&val);
			update(1,t1,t2,val);
		}
	}	
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值