最短路:HDU2962

 

Trucking

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11834    Accepted Submission(s): 1216


 

Problem Description

A certain local trucking company would like to transport some goods on a cargo truck from one place to another. It is desirable to transport as much goods as possible each trip. Unfortunately, one cannot always use the roads in the shortest route: some roads may have obstacles (e.g. bridge overpass, tunnels) which limit heights of the goods transported. Therefore, the company would like to transport as much as possible each trip, and then choose the shortest route that can be used to transport that amount.

For the given cargo truck, maximizing the height of the goods transported is equivalent to maximizing the amount of goods transported. For safety reasons, there is a certain height limit for the cargo truck which cannot be exceeded.

 

 

Input

The input consists of a number of cases. Each case starts with two integers, separated by a space, on a line. These two integers are the number of cities (C) and the number of roads (R). There are at most 1000 cities, numbered from 1. This is followed by R lines each containing the city numbers of the cities connected by that road, the maximum height allowed on that road, and the length of that road. The maximum height for each road is a positive integer, except that a height of -1 indicates that there is no height limit on that road. The length of each road is a positive integer at most 1000. Every road can be travelled in both directions, and there is at most one road connecting each distinct pair of cities. Finally, the last line of each case consists of the start and end city numbers, as well as the height limit (a positive integer) of the cargo truck. The input terminates when C = R = 0.

 

 

Output

For each case, print the case number followed by the maximum height of the cargo truck allowed and the length of the shortest route. Use the format as shown in the sample output. If it is not possible to reach the end city from the start city, print "cannot reach destination" after the case number. Print a blank line between the output of the cases.

 

 

Sample Input

 

5 6 1 2 7 5 1 3 4 2 2 4 -1 10 2 5 2 4 3 4 10 1 4 5 8 5 1 5 10 5 6 1 2 7 5 1 3 4 2 2 4 -1 10 2 5 2 4 3 4 10 1 4 5 8 5 1 5 4 3 1 1 2 -1 100 1 3 10 0 0

 

 

Sample Output

 

Case 1: maximum height = 7 length of shortest route = 20 Case 2: maximum height = 4 length of shortest route = 8 Case 3: cannot reach destination

 

二分+最短路

#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
using namespace std;
const int MAXN=1010;
#define INF 0x3f3f3f3f
struct qnode{
	int v;
	int c;
	int height;
	qnode(int _v=0,int _c=0, int _height = 0):v(_v),c(_c), height(_height){}
	bool operator <(const qnode &r)const{
		return c>r.c;
	}
};
struct Edge{
	int v,cost, height;
	Edge(int _v=0,int _cost=0, int _height = 0):v(_v),cost(_cost),height(_height){}
};
vector<Edge>E[MAXN];
bool vis[MAXN];
int dist[MAXN];
int n, m;
void Dijkstra(int n,int start, int maxn){
	memset(vis,false,sizeof(vis));
	for(int i=1;i<=n;i++)dist[i]=INF;
	priority_queue<qnode>que;
	while(!que.empty())que.pop();
	dist[start]=0;
	que.push(qnode(start,0));
	qnode tmp;
	while(!que.empty()){
		tmp=que.top();
		que.pop();
		int u=tmp.v;
		if(vis[u])continue;
		vis[u]=true;
		for(int i=0;i<E[u].size();i++){
			int v=E[tmp.v][i].v;
			int cost=E[u][i].cost;
			if(!vis[v]&&dist[v]>dist[u]+cost && E[tmp.v][i].height >= maxn){
				dist[v]=dist[u]+cost;
				que.push(qnode(v,dist[v]));
			}
		}
	}
}
void addedge(int u, int v, int w, int h){
	E[u].push_back(Edge(v, w, h));
}
int main()
{
	int kase = 1;
	while(~scanf("%d%d", &n, &m))
	{
		if(n == 0 && m == 0) break;
		for(int i = 1; i <= n; i++) E[i].clear();
		for(int i = 0; i < m; i++)
		{
			int u, v, w, h;
			scanf("%d%d%d%d", &u, &v, &h, &w);
			if(h == -1) h = INF;
			addedge(u, v, w, h);
			addedge(v, u, w, h);
		}
		int s, t, maxn;
		scanf("%d%d%d", &s, &t, &maxn);
		int l = 1, r = maxn;
		int ans = -1, route = -1;
		while(l <= r)
		{
			int mid = (l + r) >> 1;
			Dijkstra(n, s, mid);
			if(dist[t] != INF)
			{
				ans = mid;
				route = dist[t];
				l = mid + 1;
			}
			else r = mid - 1;
		}
		if(kase != 1) printf("\n");
		printf("Case %d:\n", kase++);
		if(ans != -1)
		{
			printf("maximum height = %d\nlength of shortest route = %d\n", ans, route);
		}
		else
		{
			printf("cannot reach destination\n");
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值