Pick apples

Pick apples

Time Limit: 1000MS Memory limit: 165536K

题目描述

Once ago, there is a mystery yard which only produces three kinds of apples. The number of each kind is infinite. A girl carrying a big bag comes into the yard. She is so surprised because she has never seen so many apples before. Each kind of apple has a size and a price to be sold. Now the little girl wants to gain more profits, but she does not know how. So she asks you for help, and tell she the most profits she can gain.

输入

In the first line there is an integer T (T <= 50), indicates the number of test cases.
In each case, there are four lines. In the first three lines, there are two integers S and P in each line, which indicates the size (1 <= S<= 100) and the price (1 <= P <= 10000) of this kind of apple.

In the fourth line there is an integer V,(1 <= V <= 100,000,000)indicates the volume of the girl‘s bag.

输出

For each case, first output the case number then follow the most profits she can gain.

示例输入

1 1
1 2 
1 3 
1 6

示例输出

Case 1: 6

题意:

有三种苹果,每种苹果都有自己的价格和质量,并且苹果每种苹果都有无数个,给定背包装苹果,问背包价值最高为多少


解题思路:

小范围用背包思想,大范围先贪心后背包

具体代码:

#include<iostream>
#include<cstdio>
#include<bits/stdc++.h>
using namespace std;
const int lmc=1000000;
struct node{
    int p,m;
    int pri;
}pon[3];
long long dp[2*lmc+1],v;
bool pma(node a,node b)
{
    a.pri>a.pri;
}
void work()
{
    for(int i=0;i<3;i++)
        {
            for(int j=pon[i].m;j<=v;j++)
            {
                dp[j]=max(dp[j],dp[j-pon[i].m]+pon[i].p);
            }
        }
}
int main()
{
    int t;
    scanf("%d",&t);
    int c=1;
    while(t--)
    {
        memset(dp,0,sizeof(dp));
        for(int i=0;i<3;i++)
        {
            scanf("%d %d",&pon[i].m,&pon[i].p);
            pon[i].pri=pon[i].m*1.0/pon[i].p;
        }
        scanf("%d",&v);
        if(v<lmc)
        {
            work();
            printf("Case %d:%d\n",c++,dp[v]);
        }
        else
        {
            sort(pon,pon+3,pma);
            v=v-lmc;
            long long ans=0;
            ans=ans+v/pon[0].m*pon[0].p;
            v=lmc+v-v/pon[0].m*pon[0].m;
            work();
            printf("Case %d:%d\n",c++,dp[v]+ans);
        }
    }
    return 0;
}


 
  
 
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值