HUSTOJ 进阶题组1 问题 F Seinfeld

文章讲述了如何通过编程解决一个问题,给定一个仅由花括号组成的字符串,目标是找到将它转换为稳定(平衡)状态所需的最少操作次数,允许的操作包括替换一个左括号为右括号或反之。
摘要由CSDN通过智能技术生成
题目描述

I’m out of stories. For years I’ve been writing stories, some rather silly, just to make simple problems look difficult and complex problems look easy. But, alas, not for this one.
You’re given a non empty string made in its entirety from opening and closing braces. Your task is to find the minimum number of “operations” needed to make the string stable. The definition for being stable is as follows:
1. An empty string is stable.
2. If S is stable, then {S} is also stable.
3. If S and T are both stable, then ST (the concatenation of the two) is also stable.
All of these strings are stable: {}, {}{}, and {{}{}}; But none of these: }{, {{}{, nor {}{.
The only operation allowed on the string is to replace an opening brace with a closing brace, or visa-versa.

输入

Your program will be tested on one or more data sets. Each data set is described on a single line. The line is a non-empty string of opening and closing braces and nothing else. No string has more than 2000 braces. All sequences are of even length.
The last line of the input is made of one or more ’-’ (minus signs.)

输出

For each test case, print the following line:
k. N
Where k is the test case number (starting at one,) and N is the minimum number of operations needed to convert the given string into a balanced one.
Note: There is a blank space before N.

样例输入 Copy
}{
{}{}{}
{{{}
---
样例输出 Copy
1. 2
2. 0
3. 1
#include<iostream>
#include<stack>
#include<string>
using namespace std;

int main()
{
	int times = 1;
	string s;

	//直接读取一行
	while (getline(cin, s)) {
		//如果读取到的一行中存在“-”,则终止
		if (s.find('-') != s.npos)
			break;

		stack<char> st;
		int sum = 0;
		bool flag = true;

		for (int i = 0; i < s.size(); i++) {
			//若栈非空
			if (st.empty() == false) {
				if (st.top() == '{') {
					if (s[i] == '{')
						st.push('{');
					else {
						st.pop();
					}
				}
				else {
					//如果栈顶是},则匹配不上,那么就压栈就好了
					st.push(s[i]);
				}
			}
			else {
				st.push(s[i]);
			}
		}
		char x, y;
		while (st.empty() == false) {
			x = st.top();
			st.pop();
			y = st.top();
			st.pop();
			if (x == y)   //为{{或}}
				sum++;
			else {        //为}{
				sum += 2;
			}
		}
		cout << times++ << ". " << sum << endl;
	}
	return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值