HDU - 6188 Duizi and Shunzi

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=6188

题目:

Nike likes playing cards and makes a problem of it. 

Now give you n integers, ai(1≤i≤n)ai(1≤i≤n) 

We define two identical numbers (eg: 2,22,2) a Duizi, 
and three consecutive positive integers (eg: 2,3,42,3,4) a Shunzi. 

Now you want to use these integers to form Shunzi and Duizi as many as possible. 

Let s be the total number of the Shunzi and the Duizi you formed. 

Try to calculate max(s)max(s). 

Each number can be used only once. 

Input

The input contains several test cases. 

For each test case, the first line contains one integer n(1≤n≤1061≤n≤106). 
Then the next line contains n space-separated integers aiai (1≤ai≤n1≤ai≤n) 

Output

For each test case, output the answer in a line. 

Sample Input

7
1 2 3 4 5 6 7
9
1 1 1 2 2 2 3 3 3
6
2 2 3 3 3 3 
6
1 2 3 3 4 5

Sample Output

2
4
3
2  

Hint

Case 1(1,2,3)(4,5,6)

Case 2(1,2,3)(1,1)(2,2)(3,3)

Case 3(2,2)(3,3)(3,3)

Case 4(1,2,3)(3,4,5)

分析:

给你一组数,你要找对子和顺子一共多少。水题。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF){
        int a;
        int m[100001];
        memset(m,0,sizeof(m));
        for(int i=0;i<n;i++){
            cin>>a;
            m[a]++;
        }
        int sum=0;
        for(int i=1;i<=n;){
            if(m[i]%2==1&&m[i+1]%2==1&&m[i+2]){sum++;m[i]--;m[i+1]--;m[i+2]--;}
            sum=sum+m[i]/2;
            i++;
        }
        cout<<sum<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值