Find The Multiple

Find The Multiple

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 74206Accepted: 29145Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

全文大意:

给出一个整数n,(1 <= n <= 200)。求出任意一个它的倍数m,要求m必须只由十进制的'0'或'1'组成

思路:

如果暴力枚举,一个for循环,越简单的代码,等待起来越着急(TLE)

题目要求只有0和1构成,即存在规律,每一位只有0和1,想着想着就想到了搜索……

怎么搜?

按位搜

每一位只有两种可能,0或者1,所以递归的情况就是加一位0或者加一位1,加的时候是往前加,每次加一位是加在后面(为什么?简单啊……)。搜到什么时候结束?大概搜个19位就有答案了,再大longlong就扛不住了

所以代码如下……

去AC:1426 -- Find The Multiple

​//利用dfs的方式进行搜索  对每一位进行搜索 如果满足 就退出
#include <iostream>
// #include <cstdio>
// #include <cstring>
using namespace std;
int flag=0;
long long n;
void dfs(int step,long long num)
{
    if(flag||step>=19)//步数超过19步 或者已经找到 结束搜索
    {
        return ;
    }
    if(num%n==0)//判断num是不是要找的数字
    {
        printf("%lld\n",num);
        flag=1;
        return ;
    }
    dfs(step+1,num*10);//+0
    dfs(step+1,num*10+1);//+1
}
int main()
{
    while(cin>>n)
    {
        if(n==0)
        {
           break;
        }
        flag=0;
        dfs(0,1);
    }
}

​

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值