Can you solve this equation?

12 篇文章 0 订阅

Can you solve this equation?

Now,given the equation 8x^4 + 7x^3 + 2x^2 + 3x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2
100
-4

Sample Output

1.6152
No solution!

题目翻译

给这样一个等式 8x^4 + 7x^3 + 2x^2 + 3x + 6 == Y
第一行输入n,下面n行每次输入一个数y,看看有没有符合等式的x
如果有就输出x保留四位小数,如果没有就输出No solution!或者输入的数超过100或小于0。

题目分析

因为有小数的参与,数据很大,需要二分法去查找,二分法查找用于判断,保留四位小数,只要二分法查找的数x代入后的结果与y相比,差值小于0.00001的话就算找到了

代码实现

#include<cstdio>
#include<iostream>
#include<math.h>//绝对值
using namespace std;
typedef long long ll;
double judge(double x)
{
	return 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6;
}
int main()
{
	int n;
	double y;
	while(scanf("%d",&n)!=EOF)
	{
		while(n--)
		{
			double h=0.0,t=100.0;
			scanf("%lf",&y);
			if(y<judge(0)||y>judge(100)) 
			{
				printf("No solution!\n");
				continue;//不执行下面的语句,直接返回到while循环处
			}
			double mid=50.0;
			while(fabs(judge(mid)-y)>1e-5)//差值小于0.00001的话就可以了
			{
				if(judge(mid)>y)
				{
					t=mid;
					mid=(h+t)/2.0;
				}
				else
				{
					h=mid;
					mid=(h+t)/2.0;
				}
			}
			printf("%.4lf\n",mid);
		}	
	}	
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值