CSU-ACM2017暑期训练4-dfs E - The Settlers of Catan POJ - 2258

题目:

Within Settlers of Catan, the 1995 German game of the year, players attempt to dominate an island by building roads, settlements and cities across its uncharted wilderness. 
You are employed by a software company that just has decided to develop a computer version of this game, and you are chosen to implement one of the game's special rules: 

When the game ends, the player who built the longest road gains two extra victory points. 
The problem here is that the players usually build complex road networks and not just one linear path. Therefore, determining the longest road is not trivial (although human players usually see it immediately). 
Compared to the original game, we will solve a simplified problem here: You are given a set of nodes (cities) and a set of edges (road segments) of length 1 connecting the nodes. 
The longest road is defined as the longest path within the network that doesn't use an edge twice. Nodes may be visited more than once, though. 

Example: The following network contains a road of length 12. 
o      o--o      o

 \    /    \    /

  o--o      o--o

 /    \    /    \

o      o--o      o--o

           \    /

            o--o

Input
The input will contain one or more test cases. 
The first line of each test case contains two integers: the number of nodes n (2<=n<=25) and the number of edges m (1<=m<=25). The next m lines describe the m edges. Each edge is given by the numbers of the two nodes connected by it. Nodes are numbered from 0 to n-1. Edges are undirected. Nodes have degrees of three or less. The network is not neccessarily connected. 
Input will be terminated by two values of 0 for n and m.
Output
For each test case, print the length of the longest road on a single line.
Sample Input
3 2
0 1
1 2
15 16
0 2
1 2
2 3
3 4
3 5
4 6
5 7
6 8
7 8
7 9
8 10
9 11
10 12
11 12
10 13
12 14
0 0
Sample Output
2
12

          题目大意:给你一个无向图,权值都为1,求里面的最长路径。
          思路:直接搜索,book数组用来记录同一条边是否重复遍历,避免两个点之间来回走的情况,点可以重复遍历,然后中间记得更新最大值即可。

 代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<bitset>
#include<cstdlib>
#include<cmath>
#include<set>
#include<list>
#include<deque>
#include<map>
#include<queue>
using namespace std;
typedef long long ll;
const double PI = acos(-1.0);
const double eps = 1e-6;
const int INF = 1000000000;
const int maxn = 100;

int T,n,m;
int u,v;
int max_road;
int maps[33][33];
int book[33][33];

void dfs(int node,int road)
{
    for(int i=0;i<n;i++)
    {
        if(!maps[node][i]||!maps[i][node])
            continue;
        if(book[node][i]||book[i][node])
            continue;
        book[node][i]=book[i][node]=1;
        road++;
        max_road=max(road,max_road);
        dfs(i,road);
        book[node][i]=book[i][node]=0;
        road--;
    }
}

int main()
{

	while(scanf("%d%d",&n,&m)!=EOF&&n+m)
    {
        memset(maps,0,sizeof(maps));
        max_road=0;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&u,&v);
            maps[u][v]=maps[v][u]=1;
        }
        for(int i=0;i<n;i++)
        {
            memset(book,0,sizeof(book));
            dfs(i,0);
        }
        printf("%d\n",max_road);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值