The Settlers of Catan

The Settlers of Catan

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1613 Accepted: 1054

Description

Within Settlers of Catan, the 1995 German game of the year, players attempt to dominate an island by building roads, settlements and cities across its uncharted wilderness.
You are employed by a software company that just has decided to develop a computer version of this game, and you are chosen to implement one of the game's special rules:

When the game ends, the player who built the longest road gains two extra victory points.
The problem here is that the players usually build complex road networks and not just one linear path. Therefore, determining the longest road is not trivial (although human players usually see it immediately).
Compared to the original game, we will solve a simplified problem here: You are given a set of nodes (cities) and a set of edges (road segments) of length 1 connecting the nodes.
The longest road is defined as the longest path within the network that doesn't use an edge twice. Nodes may be visited more than once, though.

Example: The following network contains a road of length 12.
o      o--o      o

 \    /    \    /

  o--o      o--o

 /    \    /    \

o      o--o      o--o

           \    /

            o--o

Input

The input will contain one or more test cases.
The first line of each test case contains two integers: the number of nodes n (2<=n<=25) and the number of edges m (1<=m<=25). The next m lines describe the m edges. Each edge is given by the numbers of the two nodes connected by it. Nodes are numbered from 0 to n-1. Edges are undirected. Nodes have degrees of three or less. The network is not neccessarily connected.
Input will be terminated by two values of 0 for n and m.

Output

For each test case, print the length of the longest road on a single line.

Sample Input

3 2
0 1
1 2
15 16
0 2
1 2
2 3
3 4
3 5
4 6
5 7
6 8
7 8
7 9
8 10
9 11
10 12
11 12
10 13
12 14
0 0

Sample Output

2
12

Source

Ulm Local 1998

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top


感觉回溯的最大的一个特点就是在其中一次递归的过程中修改变量后要恢复原状,而且过程跟DFs类似,思路明白了就好做了,这题也一样,题目说找一条最长的路,每两个节点的路径只能走一次,节点可以走多次,我是将将有路径的节点标记好,走过后将这条路径删掉,然后遍历回来的再把这条路恢复,走到一节点该节点没有路径可走的时候判断是否为最长

 寻找最长欧拉回路

#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int maxn=60;
int n,m,ans;
int p[maxn][maxn];//记录点到点之间是否连通 连通的话标志为1 
int vis[maxn][maxn];
void dfs(int u,int len)//参数 进入的点和走过边的长度
{
    ans=max(ans,len);
    for(int i=0; i<n; i++)
    {
        if(p[u][i]==0||vis[u][i]==1)continue;//如果该条边走过或者是被挑选记录走过  跳过
        vis[u][i]=vis[i][u]=1;//挑选该条边标记为走过
        dfs(i,len+1);//找这条边以后的点
        vis[u][i]=vis[i][u]=0;//将挑选过的边标记为没走过 便于回溯再次查找其他路经时刷新路没被走过
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)
            break;
        memset(p,0,sizeof(p));
        for(int i=1; i<=m; i++)
        {
            int l,r;
            scanf("%d%d",&l,&r);
            p[l][r]=p[r][l]=1;
        }
        ans=0;
        for(int i=0; i<n; i++)
        {
            memset(vis,0,sizeof(vis));
            dfs(i,0);//把每个点都当作起始点走一遍找到最大的边数
        }
        printf("%d\n",ans);
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值