hdu In Action-最短路+01背包

题目:

Since 1945, when the first nuclear bomb was exploded by the Manhattan Project team in the US, the number of nuclear weapons have soared across the globe.
Nowadays,the crazy boy in FZU named AekdyCoin possesses some nuclear weapons and wanna destroy our world. Fortunately, our mysterious spy-net has gotten his plan. Now, we need to stop it.
But the arduous task is obviously not easy. First of all, we know that the operating system of the nuclear weapon consists of some connected electric stations, which forms a huge and complex electric network. Every electric station has its power value. To start the nuclear weapon, it must cost half of the electric network’s power. So first of all, we need to make more than half of the power diasbled. Our tanks are ready for our action in the base(ID is 0), and we must drive them on the road. As for a electric station, we control them if and only if our tanks stop there. 1 unit distance costs 1 unit oil. And we have enough tanks to use.
Now our commander wants to know the minimal oil cost in this action.
Input
The first line of the input contains a single integer T, specifying the number of testcase in the file.
For each case, first line is the integer n(1<= n<= 100), m(1<= m<= 10000), specifying the number of the stations(the IDs are 1,2,3…n), and the number of the roads between the station(bi-direction).
Then m lines follow, each line is interger st(0<= st<= n), ed(0<= ed<= n), dis(0<= dis<= 100), specifying the start point, end point, and the distance between.
Then n lines follow, each line is a interger pow(1<= pow<= 100), specifying the electric station’s power by ID order.
Output
The minimal oil cost in this action.
If not exist print “impossible”(without quotes).

Sample Input
2
2 3
0 2 9
2 1 3
1 0 2
1
3
2 1
2 1 3
1
3

Sample Output
5
impossible

题意:

有n个核电站,每个核电站有一定的能源,现要毁灭一些核电站,使得剩下的核电站的能源小于初始能源总和的一半。每毁坏一个核电站需要一辆坦克,且坦克只能摧毁一个核电站。现给你核电站之间的路,你从0开始派坦克出发,问最少油耗。

思路:

先floyd求出每个核电站到0的距离,然后以总距离为背包容量,每个核电站离0点的距离为物体重量,核电站能量为价值去做01背包。

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<bitset>
#include<cstdlib>
#include<cmath>
#include<set>
#include<list>
#include<deque>
#include<map>
#include<queue>
using namespace std;
typedef long long ll;
const double PI = acos(-1.0);
const double eps = 1e-6;
const int INF = 0x3f3f3f3f;
const int maxn = 123;
int T,n,m;
int maps[maxn][maxn];
int val[maxn],dis[maxn];
int dp[maxn*maxn];
int flag,sum,sum_val;

void floyd()
{
    for(int k=0;k<=n;k++)
    {
        for(int i=0;i<=n;i++)
        {
            for(int j=0;j<=n;j++)
            {
                if(maps[i][j]>maps[i][k]+maps[k][j])
                    maps[i][j]=maps[i][k]+maps[k][j];
            }
        }
    }
    for(int i=1;i<=n;i++)
    {
        dis[i]=maps[0][i];
        if(dis[i]!=INF)
            sum+=maps[0][i];
    }
}

int main()
{
    scanf("%d",&T);
    while(T--)
    {
        flag=sum_val=sum=0;
        memset(maps,INF,sizeof(maps));
        memset(dp,0,sizeof(dp));;
        scanf("%d%d",&n,&m);
        for(int i=0;i<m;i++)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            if(maps[a][b]>c)
                maps[a][b]=maps[b][a]=c;
        }
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&val[i]);
            sum_val+=val[i];
        }
        floyd();
        for(int i=1;i<=n;i++)
        {
            for(int j=sum;j>=dis[i];j--)
            {
                dp[j]=max(dp[j],dp[j-dis[i]]+val[i]);
            }
        }
        for(int i=1;i<=sum;i++)
        {
            if(dp[i]>sum_val/2.0)
            {
                flag=1;
                printf("%d\n",i);
                break;
            }
        }
        if(!flag)
            printf("impossible\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值