HDU ~ 1385 ~ Minimum Transport Cost(floyd+打印路径)

题目网址:Minimum Transport Cost

Minimum Transport Cost

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.


Sample Input
  
  
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0

Sample Output
  
  
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17

Source

Recommend
Eddy

题意:先给你一个数字N,表示有N个城市,然后给你一个N*N的图,第x行y列表示X->Y城市需要花费多少钱;然后下面一行再给你N个数字表示你到这个城市还要交一部分钱,下面每行给你两个数字问你第一个城市到第二个城市最少花费是多少;并且打印最短路径;

思路:floyd;用一个path数组保存路径,存path当前位置需要到哪个城市去,打印路径时一直顺着输出就行了;

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
const int INF=0x3f3f3f3f;
const maxn=1005;
int a[maxn][maxn],path[maxn][maxn],money[maxn],n,b,c;
void floyd()
{
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<=n;j++)
		{
			path[i][j]=j;
		} 
	}      
	for(int k=1;k<=n;k++)
	{
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				if(a[i][k]+a[k][j]+money[k]<a[i][j])
				{
					a[i][j]=a[i][k]+a[k][j]+money[k];
					path[i][j]=path[i][k];//路径 
				}
//path[i][j] 中存的是i到j路径的第2个点, 比如1->2->3, path[1][3]存的是2, path[2][3] = 3;
				else if(a[i][j]==a[i][k]+a[k][j]+money[k])//字典序 
				{
					path[i][j]=min(path[i][j],path[i][k]); 
				}
			}
		}
	}
}
main()
{
	while(cin>>n)
	{
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				cin>>a[i][j];
				if(a[i][j]==-1)
				{
					a[i][j]=INF;
				}
			}
		}
		for(int i=1;i<=n;i++)
		{
			cin>>money[i];
		}
		floyd();
		while(cin>>b>>c,b!=-1)
		{
			int w=b;
			cout<<"From "<<b<<" to "<<c<<" :"<<endl;
			cout<<"Path: ";
			while(w!=c)
			{
				cout<<w<<"-->";
				w=path[w][c];
			}
			cout<<w<<endl;
			cout<<"Total cost : "<<a[b][c]<<endl<<endl;
		}
	}	
} 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值