Terrible Sets (单调队列)

Problem Description
Let N be the set of all natural numbers {0 , 1 , 2 , . . . }, and R be the set of all real numbers. wi, hi for i = 1 . . . n are some elements in N, and w0 = 0.
Define set B = {< x, y > | x, y ∈ R and there exists an index i > 0 such that 0 <= y <= hi ,∑ 0<=j<=i-1wj <= x <= ∑ 0<=j<=iwj}
Again, define set S = {A| A = WH for some W , H ∈ R + and there exists x0, y0 in N such that the set T = { < x , y > | x, y ∈ R and x0 <= x <= x0 +W and y0 <= y <= y0 + H} is contained in set B}.
Your mission now. What is Max(S)?
Wow, it looks like a terrible problem. Problems that appear to be terrible are sometimes actually easy.
But for this one, believe me, it's difficult.
 

Input
The input consists of several test cases. For each case, n is given in a single line, and then followed by n lines, each containing wi and hi separated by a single space. The last line of the input is an single integer -1, indicating the end of input. You may assume that 1 <= n <= 50000 and w<sub>1</sub>h<sub>1</sub>+w<sub>2</sub>h<sub>2</sub>+...+w<sub>n</sub>h<sub>n</sub> < 10<sup>9</sup>.
 

Output
Simply output Max(S) in a single line for each case.
 

Sample Input
  
  
3 1 2 3 4 1 2 3 3 4 1 2 3 4 -1
 

Sample Output
  
  
12 14

题目大概:

在x轴上有很多宽度高度不一样的矩形,问最大的矩形面积是多少。

思路:

这个题和前几天做的题都很相似,都是维护两个单调队列,一个求在i这个数左边比这个矩形高的连续矩形有几个,另一个是求右面的,然后就是长宽乘积求最大面积。

代码:

#include <iostream>
#include <cmath>
#include <cstdio>
#include <cstring>

using namespace std;

int n;
int a[55000];
int l[55000];
int r[55000];
int q[55000];
int b[55000];

int getl()
{


    for(int i=2;i<=n;i++)
    {
        while(l[i]>1&&a[i]<=a[l[i]-1])
        l[i]=l[l[i]-1];


    }
}

int getr()
{

      for(int i=n;i>=1;i--)
    {
        while(r[i]<=n&&a[i]<=a[r[i]+1])
        r[i]=r[r[i]+1];


    }
}


int main()
{

    while(scanf("%d",&n))
    {if(n==-1)break;
    memset(a,0,sizeof(a));

    memset(q,0,sizeof(q));

    b[0]=0;
    for(int i=1;i<=n;i++)
    {   int rr;
        scanf("%d%d",&rr,&a[i]);
        b[i]=b[i-1]+rr;
    }


    a[0]=a[n+1]=-1;
    for(int i=1;i<=n;i++)
    {
        l[i]=i;
        r[i]=i;
    }
    getl();
    getr();


   long long sun=-1;
    for(int i=1;i<=n;i++)
    {  long long sum=0;
        sum=(b[r[i]]-b[l[i]-1])*a[i];
        if(sum>sun)sun=sum;
    }
    printf("%d\n",sun);
    }


    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值