HDU6047-Maximum Sequence

Maximum Sequence

                                                                      Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                                Total Submission(s): 455    Accepted Submission(s): 243


Problem Description
Steph is extremely obsessed with “sequence problems” that are usually seen on magazines: Given the sequence 11, 23, 30, 35, what is the next number? Steph always finds them too easy for such a genius like himself until one day Klay comes up with a problem and ask him about it.

Given two integer sequences {ai} and {bi} with the same length n, you are to find the next n numbers of {ai}:  an+1a2n . Just like always, there are some restrictions on  an+1a2n : for each number  ai , you must choose a number  bk  from {bi}, and it must satisfy  ai ≤max{ aj -j│ bk ≤j<i}, and any  bk  can’t be chosen more than once. Apparently, there are a great many possibilities, so you are required to find max{ 2nn+1ai } modulo  109 +7 .

Now Steph finds it too hard to solve the problem, please help him.
 

Input
The input contains no more than 20 test cases.
For each test case, the first line consists of one integer n. The next line consists of n integers representing {ai}. And the third line consists of n integers representing {bi}.
1≤n≤250000, n≤a_i≤1500000, 1≤b_i≤n.
 

Output
For each test case, print the answer on one line: max{ 2nn+1ai } modulo  109 +7。
 

Sample Input
  
  
4 8 11 8 5 3 1 4 2
 

Sample Output
  
  
27
Hint
For the first sample: 1. Choose 2 from {bi}, then a_2…a_4 are available for a_5, and you can let a_5=a_2-2=9; 2. Choose 1 from {bi}, then a_1…a_5 are available for a_6, and you can let a_6=a_2-2=9;
 

Source
 


题意: 有2个数组,一个是a,一个是b,长度都为n。现在要把a数组的长度变成2n,有一个往a数组中加元素的规则,对于每一个加入i 位置的元素x,必须满足x<=max{a[j] - j│b[k] ≤ j < i},求问增加的所有元素之和最大值是多少

解题思路:现场时直接来了一发线段树过了,每次维护区间最大值,查询区间最大值即可,这题其实可以用优先队列O(n)过



#include <iostream>  
#include <cstdio>  
#include <cstring>  
#include <string>  
#include <algorithm>  
#include <map>  
#include <cmath>
#include <set>  
#include <stack>  
#include <queue>  
#include <vector>  
#include <bitset>  
#include <functional>

using namespace std;

#define LL long long  
const int INF = 0x3f3f3f3f;
const LL mod = 1000000007;

int n;
int ma[2000009];
int b[250009];

void build(int k, int l, int r)
{
    if (l == r)
    {
        if (l > n) return;
        scanf("%d", &ma[k]); ma[k] -= l;
        return;
    }
    int mid = (l + r) >> 1;
    build(k << 1, l, mid);
    build(k << 1 | 1, mid + 1, r);
    ma[k] = max(ma[k << 1], ma[k << 1 | 1]);
}

int query(int k, int l, int r, int ll, int rr)
{
    if (l >= ll&&r <= rr) return ma[k];
    int ma = -1, mid = (l + r) >> 1;
    if (mid >= ll) ma = max(ma, query(k << 1, l, mid, ll, rr));
    if (rr > mid) ma = max(ma, query(k << 1 | 1, mid + 1, r, ll, rr));
    return ma;
}

void update(int k, int l, int r, int p, int val)
{
    if (l == r) { ma[k] = val; return; }
    int mid = (l + r) >> 1;
    if (p <= mid) update(k << 1, l, mid, p, val);
    else update(k << 1 | 1, mid + 1, r, p, val);
    ma[k] = max(ma[k << 1], ma[k << 1 | 1]);
}

int main()
{
    while (~scanf("%d", &n))
    {
        build(1, 1, 2 * n);
        for (int i = 1; i <= n; i++) scanf("%d", &b[i]);
        sort(b + 1, b + 1 + n);
        LL ans = 0;
        for (int i = n + 1; i <= 2 * n; i++)
        {
            int k = query(1, 1, 2 * n, b[i - n], i - 1);
            update(1, 1, 2 * n, i, k-i);
            ans += 1LL*k;
            ans %= mod;
        }
        printf("%lld\n", ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值