HDU 1083.Courses【二分匹配】【1月2】

Course

Problem Description
Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
......
CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:
 

Sample Input
  
  
2 3 3 3 1 2 3 2 1 2 1 1 3 3 2 1 3 2 1 3 1 1
 

Sample Output
  
  
YES NO
意思是为每一门课分配一名同学。可以看一下我的另一篇文章,也是二分匹配的,这里不再赘述,上代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 310;
int T, p, n, co, st;
int f[maxn][maxn];
int s[maxn];
int sfl[maxn];
bool flag;
bool PP(int course)//为course分配学生
{
    for(int i =1;i <= n; ++i)
    {
        if(f[course][i] && !sfl[i])
        {
            sfl[i] = 1;
            if(!s[i] || PP(s[i]))
            {
                s[i] = course;
                return true;
            }
        }
    }
    return false;
}
int main()
{
    cin >> T;
    while(T--)
    {
        flag = true;
        memset(s, 0, sizeof(s));
        memset(f, 0, sizeof(f));
        scanf("%d %d", &p, &n);
        for(int i = 1;i <= p; ++i)
        {
            scanf("%d", &co);
            while(co--)
            {
                scanf("%d", &st);
                f[i][st] = 1;
            }
        }
        for(int i = 1;i <= p; ++i)
        {
            memset(sfl, 0, sizeof(sfl));
            if(!PP(i))
            {
                flag = false;
                break;
            }
        }
        if(flag) cout <<"YES\n";
        else cout <<"NO\n";
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值