hdu 5063 Operation the Sequence(思路)

Operation the Sequence

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 841    Accepted Submission(s): 287


Problem Description
You have an array consisting of n integers:  a1=1,a2=2,a3=3,,an=n . Then give you m operators, you should process all the operators in order. Each operator is one of four types:
Type1: O 1 call fun1();
Type2: O 2 call fun2();
Type3: O 3 call fun3();
Type4: Q i query current value of a[i],  this operator will have at most 50.
Global Variables: a[1…n],b[1…n];
fun1() {
index=1;
  for(i=1; i<=n; i +=2) 
    b[index++]=a[i];
  for(i=2; i<=n; i +=2)
    b[index++]=a[i];
  for(i=1; i<=n; ++i)
    a[i]=b[i];
}
fun2() {
  L = 1;R = n;
  while(L<R) {
    Swap(a[L], a[R]); 
    ++L;--R;
  }
}
fun3() {
  for(i=1; i<=n; ++i) 
    a[i]=a[i]*a[i];
}
 

Input
The first line in the input file is an integer  T(1T20) , indicating the number of test cases.
The first line of each test case contains two integer  n(0<n100000) m(0<m100000) .
Then m lines follow, each line represent an operator above.
 

Output
For each test case, output the query values, the values may be so large, you just output the values mod 1000000007(1e9+7).
 

Sample Input
  
  
1 3 5 O 1 O 2 Q 1 O 3 Q 1
 

Sample Output
  
  
2 4
 
题意:给一个n,m  表示有n个数,初始序列为1~n,m次询问
O为操作,1,2,3对应题目给的函数 Q是询问当前的第t个数是多少
思路:
直接推会超时,O(n²),这是由于我们“ 小题大做”了,我们要的结果只是一个值,而我们每次都是维护一整个序列。
所以考虑把O操作都存下来,然后每次Q就从t倒着推回初始序列,看在初始序列里是对应哪个数即可。
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define N 100010
#define mod 1000000007
int a[N];
int main()
{
    int T,t;
    int n,m;
    char op[2];
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d %d",&n,&m);
        int cnt=0;
        while(m--)
        {
            scanf("%s %d",op,&t);
            if(op[0]=='O') a[cnt++]=t;
            else if(op[0]=='Q')
            {
                int num=0;
                for(int i=cnt-1; i>=0; i--)
                {
                    if(a[i]==1)
                    {
                        if(n&1)
                        {
                            if(t<=(n/2+1)) t=1+(t-1)*2;
                            else
                            {
                                t=t-n/2-1;
                                t=2+(t-1)*2;
                            }
                        }
                        else
                        {
                            if(t<=n/2) t=1+(t-1)*2;
                            else
                            {
                                t=t-n/2;
                                t=2+(t-1)*2;
                            }
                        }
                    }
                    else if(a[i]==2) t=n-t+1;
                    else num++;
                }
                long long ans=t;
                for(int j=1; j<=num; j++)
                    ans=ans*ans%mod;
                printf("%lld\n",ans);
            }
        }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值