文章标题 Catch That Cow

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input
5 17

Sample Output
4

Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

从N到M最少几步;
两种走法:
(1)当前数加1或者减1;
(2)当前数*2;

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
using namespace std;
int N,M;
int b[200009];
struct node
{
    int x,ans;
};
int bfs(int x,int ans)
{
    node xy,xz;
    xy.x=x,xy.ans=ans;
    queue<node>s;
    s.push(xy);
    while(!s.empty())
    {
        xy=s.front();
        s.pop();
        if(xy.x==M)
        {
            return xy.ans;
        }
        for(int i=1;i<=3;i++)
        {
            if(i==1)
            {
                int xi=xy.x-1;
                if(!b[xi]&&xi>=0&&xi<=100000)
                {
                    b[xi]=1;
                    xz.x=xi,xz.ans=xy.ans+1;
                    s.push(xz);
                }
            }
            if(i==2)
            {
                int xi=xy.x+1;
                if(!b[xi]&&xi>=0&&xi<=100000)
                {
                    b[xi]=1;
                    xz.x=xi,xz.ans=xy.ans+1;
                    s.push(xz);
                }
            }
            if(i==3)
            {
                int xi=xy.x*2;
                if(!b[xi]&&xi>=0&&xi<=100000)
                {
                    b[xi]=1;
                    xz.x=xi,xz.ans=xy.ans+1;
                    s.push(xz);
                }
            }
        }
    }
    return 0;
}
int main()
{
    while(~scanf("%d%d",&N,&M))
    {
        memset(b,0,sizeof(b));
        int step=bfs(N,0);
        printf("%d\n",step);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值