Largest Rectangle in a Histogram

题目:

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 
 
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

 

思路:

 

预处理出每一个点能够向两边延伸的距离,向左找到第一个比当前点高度小的下标记为i,向右找到第一个比当前点高度小的下标记为j,那么此时以这点高度的最大值是f[i]*(j-i+1); 然后用for循环扫一遍求出最大值即可。

 

代码:

#include<stdio.h>
const int N = 100010;
__int64 f[N],l[N],r[N],sum;
int main()
{
    int n,i;
    while(scanf("%d",&n)!=EOF&&n)
    {
        sum=0;
        for(i=1;i<=n;i++)
    {
        scanf("%I64d",&f[i]);
        l[i]=r[i]=i;
    }
    f[0]=f[n+1]=-1;
    for(i=1;i<=n;i++)
    {
        while(f[i]<=f[l[i]-1])
            l[i]=l[l[i]-1];
    }
    for(i=n;i>=1;i--)
    {
        while(f[i]<=f[r[i]+1])
            r[i]=r[r[i]+1];
    }
    for(i=1;i<=n;i++)
        if(f[i]*(r[i]-l[i]+1)>sum)
        sum=f[i]*(r[i]-l[i]+1);
    printf("%I64d\n",sum);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值