a1127 ZigZagging on a Tree (中序,后序 -> 层序)

1127 ZigZagging on a Tree (30 分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

题意:给出一个二叉树的中序遍历和后序遍历,按照题目所定义的层序输出。

思路;知道二叉树的中序和前序遍历,或者中序和后序遍历,都可以按照模板建立出树来。建树时,建立一个mp向量,把相同高度的存放在一起。

 

#include <iostream>
#include "vector"
using namespace std;
vector<int> mp[33];
vector<int> post,in;
int maxlevel=0;
void insert(int posl,int posr,int inl,int inr,int depth){
    if (inl>inr) return;
    int i=inl;
    mp[depth].push_back(post[posr]);
    while (i<inr && in[i]!=post[posr]) i++;
    maxlevel=max(depth,maxlevel);
    int left = i-inl;
    insert(posl,posl+left-1,inl,i-1,depth+1);
    insert(posl+left,posr-1,i+1,inr,depth+1);
}
int main() {
    int n,temp;
    cin>>n;
    for (int i = 0; i < n; ++i) {
        cin>>temp;
        in.push_back(temp);
    }
    for (int i = 0; i < n; ++i) {
        cin>>temp;
        post.push_back(temp);
    }
    insert(0,n-1,0,n-1,0);
    for(int i=0;i<=maxlevel;i++){
        if(i%2!=0)
        {
            for(int j=0;j<mp[i].size();j++)
            {
                cout<<" ";
                cout<<mp[i][j];
            }
        }
        else{
            for(int j=mp[i].size()-1;j>=0;j--)
            {
                if(i!=0)
                    cout<<" ";
                cout<<mp[i][j];
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值