POJ 1759 Garland

Garland
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions:2653 Accepted: 1119

Description

The New Year garland consists of N lamps attached to a common wire that hangs down on the ends to which outermost lamps are affixed. The wire sags under the weight of lamp in a particular way: each lamp is hanging at the height that is 1 millimeter lower than the average height of the two adjacent lamps. 

The leftmost lamp in hanging at the height of A millimeters above the ground. You have to determine the lowest height B of the rightmost lamp so that no lamp in the garland lies on the ground though some of them may touch the ground. 

You shall neglect the lamp's size in this problem. By numbering the lamps with integers from 1 to N and denoting the ith lamp height in millimeters as Hi we derive the following equations: 

H1 = A 
Hi = (H i-1 + H i+1)/2 - 1, for all 1 < i < N 
HN = B 
Hi >= 0, for all 1 <= i <= N 

The sample garland with 8 lamps that is shown on the picture has A = 15 and B = 9.75. 

Input

The input file consists of a single line with two numbers N and A separated by a space. N (3 <= N <= 1000) is an integer representing the number of lamps in the garland, A (10 <= A <= 1000) is a real number representing the height of the leftmost lamp above the ground in millimeters.

Output

Write to the output file the single real number B accurate to two digits to the right of the decimal point representing the lowest possible height of the rightmost lamp.

Sample Input

692 532.81

Sample Output

446113.34

原式移向得h[i]=2*h[i-1]-h[i-2]+2;h[1]给出了假定一个h[2]
h[3]便确定了,由公式可推出h[i]=(i-1)*h[2]-(i-2)*h[1]+c,
c为常数,每项得c对应下面数组中的c[i].
由此可得h[2]与最后的B的高度成正比。因此可以二分求B

代码:

#include<cstdio>
#include<algorithm>
using namespace std;
double c[1003];
int main()
{
    c[3]=2;c[4]=6;
    for(int i=5;i<=1000;i++)
        c[i]=2*c[i-1]-c[i-2]+2;
    int N;double A; scanf("%d%lf",&N,&A);
    double q=0,r=A+1,B;
    while(r-q>0.00000001)
    {
        double h2=(q+r)/2;
        double t;
        for(int i=3;i<=N;i++)
        {
            t=(i-1)*h2-(i-2)*A+c[i];
            if(t<0)break;
        }
        if(t<0) q=h2;
        else
        {
            B=t;r=h2;
        }
    }
    printf("%.2lf\n",B);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值