(PAT 1118) Birds in Forest (并查集)

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤10​4​​) which is the number of pictures. Then N lines follow, each describes a picture in the format:

K B​1​​ B​2​​ ... B​K​​

where K is the number of birds in this picture, and B​i​​'s are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 10​4​​.

After the pictures there is a positive number Q (≤10​4​​) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes if the two birds belong to the same tree, or No if not.

Sample Input:

4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

Sample Output:

2 10
Yes
No

解题思路:

利用并查集解决该题,该题必须要用路径压缩,不然会超时

读入数据的时候,把每只鸟的序号读进一个set(set不允许重复),这个set的大小就是鸟的数量

最后用set的中的鸟序号去查询根节点,插入另一个set,这个set的大小就是树的棵树

#include <iostream>
#include <algorithm>
#include <set>
using namespace std;
const int MAXN = 10100;
int JFather[MAXN];
int JFind_set(int node) {
	if (JFather[node] != node) {
		JFather[node] = JFind_set(JFather[node]);
	}
	return JFather[node];
}
void JMerge(int a, int b) {
	int ancestorA = JFind_set(a);
	int ancestorB = JFind_set(b);
	if (ancestorA != ancestorB) {
		JFather[ancestorA] = ancestorB;
	}
}
int main() {
	int N;
	set<int> birdSet;
	set<int> rootSet;
	cin >> N;
	for (int i = 1; i <= MAXN; ++i) {  //初始化
		JFather[i] = i;
	}
	for (int i = 0; i < N; ++i) {
		int nums;
		cin >> nums;
		int root, nA;
		for (int j = 0; j < nums; ++j) {
			if (j == 0) { 
				cin >> root;
				birdSet.insert(root);
			}
			else {
				cin >> nA;
				JMerge(root, nA);
				birdSet.insert(nA);
			}
		}
	}
	for (auto itr = birdSet.begin(); itr != birdSet.end(); ++itr) {
		rootSet.insert(JFind_set(*itr));
	}
	cout << rootSet.size() << " " << birdSet.size() << endl;
	int K;
	cin >> K;
	for (int i = 0; i < K; ++i) {
		int na, nb;
		cin >> na >> nb;
		if (JFind_set(na) == JFind_set(nb)) {
			cout << "Yes" << endl;
		}
		else {
			cout << "No" << endl;
		}
	}
	system("PAUSE");
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值