poj2431Expedition


Expedition
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15341 Accepted: 4302

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS: 

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively. 

OUTPUT DETAILS: 

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

Source


题意就是一辆卡车,在距离终点l的位置上,然后可以行使p距离。

然后在   l到0这个区间内有n个加油站,每个加油站给你了坐标以及他们能提供的汽油,也就是能够帮助卡车走的距离数。

然后现在问你卡车能不能到达终点,如果能的话请输出最短的加油站的数量。

这个题其实就是个贪心。

对于你的卡车,位置l,可以行驶距离p;

1.

那么你下一次可以到达的位置便是l-=p;

那么如果有加油站的距离大于等于l,那么这些加油站都可以提供给卡车加油。

至于卡车要不要加,看卡车现在是不是到达终点。

没有到达终点的话,那么肯定是在可以加油的加油站中选择提供汽油最多的加。

2.此时的p便是可以加的油的一个油的最大值,此时答案加1,然后执行循环1.

知道t<0的时候,便表示到达终点了,输出答案即可。

那么什么情况会到达不了呢?循环肯定是进入死循环了,很简单:

当 t>0时,如果没有加油站可以提供加油了,那么就是到达不了了。

详情看代码中的体现。

每次取一个最大值,可以用优先队列来维护。

#include <cstdio>
#include <cstring>
#include <map>
#include <algorithm>
#include <queue>
using namespace std;
const int MAXN=1e4+7;
int n,m,k;
int l,f;
struct node
{
    int l,w;
    bool operator<(const node&a)const
    {
        return l>a.l;
    }
} p[MAXN];
int main()
{
    scanf("%d",&n);
    for(int i=0; i<n; ++i)
    {
        scanf("%d%d",&p[i].l,&p[i].w);
    }
    scanf("%d%d",&l,&f);
    sort(p,p+n);
    priority_queue<int,vector<int>,less<int> >q;
    int i=0;
    int t=l-f;
    int ans=0;
    while(t>0)
    {
        while(p[i].l>=t&&i<n)
        {
            q.push(p[i].w);
            i++;
        }
        if(!q.empty())
        {
            f=q.top();
            q.pop();
            ans++;
            t-=f;
        }
        if(t>0&&q.empty()&&p[i].l<t)//没有加油站可以提供加油了,队列空,也没有加油站可以进入队列了
        {
            puts("-1");
            return 0;
        }
    }
    printf("%d\n",ans);
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值