1017 Queueing at Bank-PAT甲级

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​4​​) - the total number of customers, and K (≤100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2

解题思路:建立一个优先级队列,时间较小的在前面,根据id值为0还是其他来判定其是顾客此时需要服务,还是窗口空闲的 情况,如果是顾客需要等待处理的话,遍历所有的窗口,看是否有未在服务的即可,如果没有,将此顾客加入等待队列;若是窗口空闲,则在顾客的等待队列中选择最前面的进行服务。

注意:题目中说是在17:00之后到达的不再服务,但是如果在17:00之前但其服务时间在17:00之后,需要等待服务完成。同时,每个人的服务时间不能超过一个小时

满分代码如下:

#include<bits/stdc++.h>
using namespace std;
int n,k;
struct Person{
	int arrive=0,serve=0;
	Person(){}
	Person(int aa,int ss){
		arrive=aa;
		serve=ss;
	}
}person[10005];
int window[105];
struct PersonWindow{
	int id=0;//窗口的编号 
	int personNum;//人的编号 
	int time;//窗口的时间 
	PersonWindow(){}
	PersonWindow(int ii,int pp,int tt){
		id=ii;
		personNum=pp;
		time=tt;
	} 
	bool operator < (const PersonWindow &a)const{
		return time>a.time;
	}
};
int search(){
	for(int i=1;i<=k;i++){
		if(!window[i]){
			return i;
		}
	}
	return -1;
}
priority_queue<PersonWindow>personwindow;
list<int>waitperson;
const int first=8*3600,last=17*3600;
int main(){
	memset(window,0,sizeof(window));
	scanf("%d%d",&n,&k);
	for(int i=0;i<n;i++){
		int h,m,s,serve;
		scanf("%d:%d:%d%d",&h,&m,&s,&serve);
		int tt=(h*60+m)*60+s;
		serve*=60;
		serve=min(serve,60*60);
		if(tt<last){
			person[i]={tt,serve};
		    personwindow.push({0,i,person[i].arrive});
		}
	}
	double sum=0;//总的等待时间
	int num=0;//总的服务人数 
	while(!personwindow.empty()){
		PersonWindow p=personwindow.top();
		personwindow.pop();
		if(p.time<first){
			p.time=first;
		}
		if(p.id==0){
			//需要进行服务的人
			int index=search();
			if(index==-1){
				//没有可用的窗口,加入等待队列
				waitperson.push_back(p.personNum); 
			}else{
				//有可用的窗口
				window[index]=1;//表示正在使用
				num++;
				sum+=(p.time-person[p.personNum].arrive);
				personwindow.push({index,p.personNum,p.time+person[p.personNum].serve});	 
			}
		}else{
			//表示有窗口出现了空闲
			if(waitperson.empty()){
				//等待队列中没有人
				window[p.id]=0;//空闲标志 
			}else{
				int temp;
				temp=waitperson.front();
				waitperson.pop_front();
				num++;
				sum+=(p.time-person[temp].arrive);
				personwindow.push({p.id,temp,p.time+person[temp].serve});
			}
		}
	}
	printf("%.1f\n",(sum/60)/num);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Queueing theory is a mathematical study of waiting lines or queues that arise in various real-life scenarios, such as customer service, traffic congestion, hospital emergency rooms, and telecommunications networks. Basic queueing theory involves the following concepts: 1. Arrival Process: This is the process of customers arriving at the queue. The arrival process can be modeled using different distributions, such as Poisson or exponential. 2. Service Process: This is the process of serving customers in the queue. The service process can also be modeled using different distributions, such as Poisson or exponential. 3. Queue Length: This is the number of customers waiting in the queue at any given time. 4. Queue Occupancy: This is the proportion of time that the server is busy serving customers. 5. System Capacity: This is the maximum number of customers that the system can handle at any given time. 6. Utilization: This is the proportion of time that the server is busy serving customers compared to the total time. 7. Waiting Time: This is the time that a customer spends waiting in the queue before being served. 8. Service Time: This is the time that a customer spends being served by the server. 9. Queueing Models: There are different queueing models that can be used to analyze queueing systems, such as the M/M/1 model, M/M/c model, M/G/1 model, and M/D/1 model. 10. Performance Measures: Different performance measures can be used to evaluate queueing systems, such as average waiting time, average queue length, and system throughput.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值