1038 Recover the Smallest Number-PAT甲级

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​4​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

假如给定两个字符串string a="32",b="321";显然只能形成两种数字32321和32132,则字符串b放在前面形成的字符串表较小。所以判断两个字符串形成的两种数字那个更小只需对a+b和b+a的字典序比较即可。将上述比较方法写入比较函数中,然后用sort函数将所有字符串进行排序,就可以得出符合要求的字符串的排列情况。
满分代码如下:

#include<bits/stdc++.h>
using namespace std;
vector<string>ve;
bool cmp(string a,string b){
	return a+b<b+a;
} 
int main(){
	int n;
	scanf("%d",&n);
	string t;
	for(int i=0;i<n;i++){
		cin>>t;
		ve.push_back(t);
	}
	sort(ve.begin(),ve.end(),cmp);
	string s="";
	for(int i=0;i<ve.size();i++){
		s+=ve[i];
	}
	int i;
	while(i<s.size()&&s[i]=='0')//不能输出前导0
		i++;
	if(i==s.size())
		printf("0");
	else{
		for(;i<s.size();i++)
			printf("%c",s[i]);
	} 
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值