【PAT】1121. Damn Single (25)【哈希表】

题目描述

“Damn Single (单身狗)” is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

翻译:单身狗是中国对单身的人的绰号。你需要找出那些在一场大型派对上单身的人,这样他们可以就会被关照了。

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID’s which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (≤ 10,000) followed by M ID’s of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

翻译:每个输入文件包含一组测试数据。对于每组测试数据,第一行包括两个正整数N (≤ 50,000),表示情侣的总人数。接下来给出N行情侣,每一行给出一对情侣的五位数字编号 (i.e. from 00000 to 99999)。在情侣列表后面,包含一个正整数M (≤ 10,000) ,跟着M个派对嘉宾的编号。数字之间用空格隔开。数据保证没有人有重婚或和多名女性拍拖的情况。


Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID’s in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

翻译:输出一行单身嘉宾的数量。接下来,一行, 按照升序输出它们的ID。数字之间必须用空格隔开,并且行末尾不能有多余空格。


Sample Input:

3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333


Sample Output:

5
10000 23333 44444 55555 88888


解题思路

用哈希表记录每对情侣。然后对嘉宾数组进行排序,如果情侣双方都在则跳过。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#define INF 99999999
using namespace std;
int N,Hash[100000];
int M,Party[10010];
int v[50010];//记录couple对来的人 
int main(){
	scanf("%d",&N);
	int a,b;
	for(int i=1;i<=N;i++){
		scanf("%d%d",&a,&b);
		Hash[a]=i;
		Hash[b]=i;
	}
	scanf("%d",&M);
	int ccount=M; 
	for(int i=0;i<M;i++){
		scanf("%d",&Party[i]);
		if(Hash[Party[i]])
		v[Hash[Party[i]]]++;
		if(v[Hash[Party[i]]]>1)ccount-=2;
	}
	sort(Party,Party+M);
	printf("%d\n",ccount);
	int flag=0;
	for(int i=0;i<M;i++){
		if(v[Hash[Party[i]]]<=1){
			if(flag==0)printf("%05d",Party[i]),flag=1;
			else	   printf(" %05d",Party[i]);
		}
	}
	if(ccount!=0)printf("\n");
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值