1032 Sharing (25 point(s)) - C语言 PAT 甲级

1032 Sharing (25 point(s))

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.
在这里插入图片描述
Figure 1
You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤ 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.
Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

题目大意:

求两个链表的首个公共节点的地址

设计思路:

首先遍历两个链表得到各自的长度;第二次遍历,先让长的链表走若干步,使剩下的长度和短的链表长度相同;然后,同时在两个链表上遍历,找到第一个相同的节点即第一个公共节点。

但本程序使用了额外的空间,让时间复杂度更极端一点(只是尽可能尝试不同的思路)。先遍历第一条链表,将访问的节点标记,再遍历第二条链表时,遇到的第一个访问过的节点,即为第一个公共节点。

编译器:C (gcc)
#include <stdio.h>

struct node {
        int next;
        int flag;
};

int main(void)
{
        struct node link[100000] = {0};
        int s1, s2, n;
        int i, a, b;
        char ch;

        scanf("%d %d %d", &s1, &s2, &n);
        for (i = 0; i < n; i++) {
                scanf("%d %c %d", &a, &ch, &b);
                link[a].next = b;
        }

        for (i = s1; i != -1; i = link[i].next) {
                link[i].flag = 1;
        }
        for (i = s2; i != -1 && link[i].flag == 0; i = link[i].next) {
                ;
        }

        if (i != -1) {
                printf("%05d", i);
        } else {
                printf("%d", i);
        }

        return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值