1127 ZigZagging on a Tree -PAT甲级

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

 

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

考察利用后序+中序来重建一颗树,同时在遍历的过程中与层次遍历法相同,不过只是在层与层的遍历上添加了方向

满分代码如下:

#include<bits/stdc++.h>
using namespace std;
const int N=33;
int in[N],post[N],n,level_sum[N];
struct node{
	int data;
	int level;
	node* lchild=NULL;
	node* rchild=NULL;
};
node *create(int postl,int postr,int inl,int inr){
	if(postl>postr){
		return NULL;
	}
	node *root=new node;
	root->data=post[postr];
	int k;
	for(k=inl;k<=inr;k++){
		if(in[k]==post[postr])
			break;
	}
	int numleft=k-inl;//左子树的个数 
	root->lchild=create(postl,postl+numleft-1,inl,k-1);
	root->rchild=create(postl+numleft,postr-1,k+1,inr);
	return root;
	
}
void layer_order(node *root,vector<int>&ve,int &lay){
	memset(level_sum,0,sizeof(level_sum));
	root->level=1;
	level_sum[1]=1;
	ve.push_back(root->data);
	queue<node *>q;
	q.push(root);
	while(!q.empty()){
		node *p=q.front();
		q.pop();
		if(p->lchild!=NULL){
			q.push(p->lchild);
			ve.push_back(p->lchild->data);
			p->lchild->level=p->level+1;
			lay=max(lay,p->lchild->level);
			level_sum[p->lchild->level]++;
		}
		if(p->rchild!=NULL){
			q.push(p->rchild);
			ve.push_back(p->rchild->data);
			p->rchild->level=p->level+1;
			lay=max(lay,p->rchild->level);
			level_sum[p->rchild->level]++;
		}
	}
}
int main(){
	cin>>n;
	for(int i=0;i<n;i++){
		cin>>in[i];
	}
	for(int i=0;i<n;i++){
		cin>>post[i];
	}
	node *root=create(0,n-1,0,n-1);
	vector<int>ve;
	int lay=-1;
	layer_order(root,ve,lay);
	int num=1;
	cout<<ve[num-1];
	for(int i=2;i<=lay;i++){
		if(i%2==0){
			for(int j=1;j<=level_sum[i];j++){
				cout<<" ";
				cout<<ve[num];
				num++;
			}	
		}else{
			int begin=num;
			num=num+level_sum[i];
			int pp=num-1;
			for(int j=pp;j>=begin;j--){
				cout<<" ";
				cout<<ve[j];
			}
		}

	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值