1143 Lowest Common Ancestor -PAT甲级

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

该题和PAT甲级1151的题一样,只不过是在二叉搜索树中隐含了中序遍历,对于二叉搜索树来说,前序遍历的的升序遍历就是中序遍历,其余做法同甲级1151

满分代码如下:

#include<bits/stdc++.h>
using namespace std;
const int N=10005;
struct node{
	int data,father=-1,level;//结点的权值,父节点以及自身在树中的深度 
	node(){}
	node(int d,int f,int l){
		data=d;
		father=f;
		level=l;
	} 
};
struct tree{
	int data;//树中结点的值
	tree *lchild=NULL;//树的左孩子分支
	tree *rchild=NULL;//树的右孩子分支 
};
node pre[N];
int m,n,in[N];
tree *create(int prel,int prer,int inl,int inr,int father,int level){
	if(prel>prer)
		return NULL;
	tree *root=new tree;
	root->data=pre[prel].data;
	int k;
	for(k=inl;k<=inr;k++){
		if(in[k]==pre[prel].data)
			break;
	}
	pre[prel]=node(pre[prel].data,father,level);
	int numleft=k-inl;
	root->lchild=create(prel+1,prel+numleft,inl,k-1,prel,level+1);
	root->rchild=create(prel+numleft+1,prer,k+1,inr,prel,level+1);
	return root;
}
map<int,int>mp;//记录某个值在前序中的下标 

int main(){
	scanf("%d%d",&m,&n);
	for(int i=0;i<n;i++){
		scanf("%d",&pre[i].data);
		in[i]=pre[i].data;
		mp[pre[i].data]=i;	
	}
	//二叉搜索树的前序遍历的升序就是中序遍历
	sort(in,in+n); 
	tree *root=create(0,n-1,0,n-1,-1,0);
	for(int i=1;i<=m;i++){
		int x,y;
		scanf("%d%d",&x,&y);
		int idx,idy;
		if(mp.find(x)==mp.end()) idx=-1;
		else idx=mp[x];
		if(mp.find(y)==mp.end()) idy=-1;
		else idy=mp[y];
		if(idx==-1&&idy==-1){
			printf("ERROR: %d and %d are not found.\n",x,y);
		}else if(idx==-1){
			printf("ERROR: %d is not found.\n",x);
		}else if(idy==-1){
			printf("ERROR: %d is not found.\n",y);
		}else{
			int flag=1;//x的深度大于y的标志
			if(pre[idx].level<pre[idy].level){
				swap(idx,idy);
				flag=0;
			} 
			while(pre[idx].level!=pre[idy].level){
				//深度不一样,x向上
				idx=pre[idx].father;//下标继续改变 
			}
			if(idx==idy){
				printf("%d is an ancestor of %d.\n",pre[idx].data,flag?x:y);
			}else{
				while(idx!=idy){
					idx=pre[idx].father;
					idy=pre[idy].father;
				}
				printf("LCA of %d and %d is %d.\n",x,y,pre[idx].data);
			}
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值