Problem D: Digit Rightmost

Problem D: Digit Rightmost

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 78   Solved: 12
[ Submit][ Status][ Web Board]

Description

Given a positive integer N, you should output the most right digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the rightmost digit of N^N.

Sample Input

2
3
4

Sample Output

7
6

HINT

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.

In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

看到这一题,我都想锤自己!一看到大数就想试试刚刚学到的


Java处理大数,效果还好,就是超时!我的个去!先贴一下


Java代码!

import java.math.BigInteger;
import java.util.Scanner;
public class Main {

	/**
	 * @param args
	 */
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner cinScanner=new Scanner(System.in);
		int n,m,f;
		n=cinScanner.nextInt();
		while ((n--)!=0) {
			
			m=cinScanner.nextInt();
			f=m;
			String s;
			s=Integer.toString(m);
			BigInteger x=new BigInteger(s);
			for (int i=1;i<f;i++) {
				s=Integer.toString(m);
				BigInteger b=new BigInteger(s);
				x=x.multiply(b);
			}
			String h=x.toString();
			//System.out.println();
			char []k=h.toCharArray();
			int l=h.length();
			System.out.println(k[l-1]);
		}
		

	}

}

后来仔细一看,尼玛这不就是快速冥运算


吗?都怪我有眼无珠带的关于快速冥运算,没有我总结的那一


个!我忘了,否则改一个参数就可以AC了,我还在考场干着急


也没有办法!关于这一节在这里,哎!A hard puzzle


这里不说了,直接上代码!


#include <stdio.h>
int pow_mod( int a,int n,int m)
{
    int ans = 1;
    a = a % m;
    while(n>0)
    {
        if(n%2 ==1)
            ans=(ans*a)%m;
        n=n/2;
        a=(a*a) % m;
    }
    return ans;
}
int main()
{
    int a,n,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
         printf("%d\n",pow_mod(n,n,10));
    }
    return 0;
}

这题就是一个眼睁睁的模板啊,把参数放进去就可以AC了!说


多了都是泪!哭哭

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值