【二分+RMQ】hdu 5289 Assignment

相同题目:点击打开链接

Assignment

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 4325    Accepted Submission(s): 1992

Problem Description
Tom owns a company and he is the boss. There are n staffs which are numbered from 1 to n in this company, and every staff has a ability. Now, Tom is going to assign a special task to some staffs who were in the same group. In a group, the difference of the ability of any two staff is less than k, and their numbers are continuous. Tom want to know the number of groups like this.
Input
In the first line a number T indicates the number of test cases. Then for each case the first line contain 2 numbers n, k (1<=n<=100000, 0<k<=10^9),indicate the company has n persons, k means the maximum difference between abilities of staff in a group is less than k. The second line contains n integers:a[1],a[2],…,a[n](0<=a[i]<=10^9),indicate the i-th staff’s ability.
Output
For each test,output the number of groups
Sample Input
  
  
2 4 2 3 1 2 4 10 5 0 3 4 5 2 1 6 7 8 9
Sample Output
  
  
5 28
Hint
First Sample, the satisfied groups include:[1,1]、[2,2]、[3,3]、[4,4] 、[2,3]
Author
FZUACM
Source
Recommend
We have carefully selected several similar problems for you:   6055  6054  6053  6052  6051 
Statistic |  Submit |  Discuss |  Note

题意:给出一个序列,找到有多少个子序列的最值差小于等于k?

思路:随着区间变大,最值差也会变大,区间最值差具有单调性,所以可以使用二分;RMQ预处理最值,固定左端点,二分右端点;

代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
typedef long long ll;

#define N 200010

int a[N], lg[N], maxx[20][N], minn[20][N];

int query(int l, int r)
{
    int k = lg[r - l + 1];
    return max(maxx[k][l], maxx[k][r - (1 << k) + 1]) - min(minn[k][l], minn[k][r - (1 << k) + 1]);
}

void get_a(int n)
{
    for(int i = 1; i <= n; i ++)
        maxx[0][i] = minn[0][i] = a[i];
    for(int i = 2; i <= n; i ++) if(i & (i - 1)) lg[i] = lg[i - 1];
        else lg[i] = lg[i - 1] + 1;
    for(int i = 1; (1 << i) <= n; i ++)
    {
        for(int j = 1; j + (1 << i) - 1 <= n; j ++)
        {
            maxx[i][j] = max(maxx[i - 1][j], maxx[i - 1][j + (1 << (i - 1))]);
            minn[i][j] = min(minn[i - 1][j], minn[i - 1][j + (1 << (i - 1))]);
        }
    }
}

int main()
{
    int n, K;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d", &n, &K);
        for(int i = 1; i <= n; i ++)
            scanf("%d", &a[i]);
        get_a(n);

        ll ans=0;
        for(int i = 1; i <= n; i ++)
        {
            int l=i,r=n,mid;
            while(l+1<r)
            {
                mid=(l+r)>>1;
                if(query(i,mid)<K)
                    l=mid;
                else
                    r=mid;
            }

            if(query(i,r)<K)
                ans+=r-i+1;
            else
                ans+=l-i+1;
        }

        printf("%lld\n",ans);
    }

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值